summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitattributes2
-rw-r--r--PKGBUILD23
-rwxr-xr-xpublish.sh17
4 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c6a41227c485
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = redir-git
+ pkgdesc = Standard IO redirection to Socket
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/comroid-git/redir
+ arch = any
+ license = GPL-3.0
+ makedepends = dotnet-sdk-6.0
+ depends = dotnet-runtime-6.0
+ options = !strip
+ source = git+https://github.com/comroid-git/redir.git
+ source = git+https://github.com/comroid-git/csapi.git
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = redir-git
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 000000000000..dfe0770424b2
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1,2 @@
+# Auto detect text files and perform LF normalization
+* text=auto
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e39acc8ace6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Tobias Burdow <kaleidox@comroid.org>
+
+pkgname=redir-git
+pkgver=0.1
+pkgrel=1
+pkgdesc="Standard IO redirection to Socket"
+arch=('any')
+url="https://github.com/comroid-git/redir"
+license=('GPL-3.0')
+depends=('dotnet-runtime-6.0')
+makedepends=('dotnet-sdk-6.0')
+source=("git+https://github.com/comroid-git/redir.git" "git+https://github.com/comroid-git/csapi.git")
+md5sums=('SKIP' 'SKIP')
+options+=("!strip")
+
+build() {
+ cd redir
+ dotnet publish -c Release --use-current-runtime
+}
+
+package() {
+ install -Dm755 "redir/redir/bin/Release/net6.0/linux-x64/publish/redir" "$pkgdir/usr/bin/redir"
+}
diff --git a/publish.sh b/publish.sh
new file mode 100755
index 000000000000..e8728a9b5bf3
--- /dev/null
+++ b/publish.sh
@@ -0,0 +1,17 @@
+#!/usr/bin/bash
+
+set -e # exit on error
+
+echo "cleanup"
+sudo rm -rf */
+
+echo "update SRCINFO"
+makepkg --printsrcinfo > .SRCINFO
+(git add .SRCINFO && git commit -m "SRCINFO") || true
+
+echo "push to aur"
+if [ -z "$(git remote | grep aur)" ]; then
+ git remote add aur ssh://aur@aur.archlinux.org/redir-git.git
+fi
+git push --set-upstream aur master
+git push --set-upstream origin master