summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da4c1abede1b..ed419bb202ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
pkgbase = redis-graph
pkgdesc = A graph database as a Redis module
- pkgver = 2.10.11
+ pkgver = 2.12.10
pkgrel = 1
url = https://redis.io/docs/stack/graph/
- arch = i686
arch = x86_64
- arch = aarch64
- arch = armv7h
license = custom:SSPL1
makedepends = git
makedepends = cmake
makedepends = peg
depends = redis
conflicts = redis-graph-git
- source = git+https://github.com/RedisGraph/RedisGraph.git
+ source = git+https://github.com/RedisGraph/RedisGraph.git#commit=3c832112b6e0a1564930ebac838d96289a57cb9a
sha256sums = SKIP
pkgname = redis-graph
diff --git a/PKGBUILD b/PKGBUILD
index 53ed53dfcbd9..89500b4f9868 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,17 @@
pkgname=redis-graph
_name=RedisGraph
-pkgver=2.10.11
+pkgver=2.12.10
pkgrel=1
pkgdesc="A graph database as a Redis module"
-arch=('i686' 'x86_64' 'aarch64' 'armv7h')
+arch=('x86_64')
url="https://redis.io/docs/stack/graph/"
license=("custom:SSPL1")
makedepends=('git' 'cmake' 'peg')
depends=('redis')
conflicts=('redis-graph-git')
-_tag=220683c4f3a0064d870b76d9dba58f81b814ef83 # git rev-parse v${pkgver}
-source=(git+https://github.com/${_name}/${_name}.git)
+_tag=3c832112b6e0a1564930ebac838d96289a57cb9a # git rev-parse v${pkgver}
+source=(git+https://github.com/${_name}/${_name}.git#commit=${_tag})
sha256sums=('SKIP')
prepare() {
@@ -29,7 +29,7 @@ build() {
package() {
cd ${_name}
- install -D src/redisgraph.so ${pkgdir}/usr/lib/redis/redisgraph.so
+ install -D bin/linux-x64-release/src/redisgraph.so ${pkgdir}/usr/lib/redis/redisgraph.so
install -Dm644 LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt
}