summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--LICENSE12
-rw-r--r--PKGBUILD13
3 files changed, 26 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dae37de33be6..f1858ff41b7f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
# Generated by mksrcinfo v8
-# Fri Jun 17 16:22:12 UTC 2016
+# Fri Jun 17 16:47:15 UTC 2016
pkgbase = redo-sh
pkgdesc = Redo implementation in Bourne Shell.
pkgver = 1.1.6
- pkgrel = 1
+ pkgrel = 2
url = http://news.dieweltistgarnichtso.net/bin/redo-sh.html
arch = any
- license = GPL
- depends = bash
+ license = custom:AGPL
+ depends = sh
conflicts = redo-c-git
conflicts = redo-git
source = http://daten.dieweltistgarnichtso.net/src/redo-v1.1.6.tar.gz
+ source = LICENSE
sha256sums = 68577c4e97b3707ab23999fa5d8886cbd509ea528a5becb40a8cc34528d7e8f5
+ sha256sums = a864db46c8406508b3cea76ab86431c56b553bac67a9df22614c3cf1dd7e734b
pkgname = redo-sh
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..d6b82cb2ac6e
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,12 @@
+# Copyright © 2014-2016 Nils Dagsson Moskopp (erlehmann)
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as
+# published by the Free Software Foundation, either version 3 of the
+# License, or (at your option) any later version.
+
+# Dieses Programm hat das Ziel, die Medienkompetenz der Leser zu
+# steigern. Gelegentlich packe ich sogar einen handfesten Buffer
+# Overflow oder eine Format String Vulnerability zwischen die anderen
+# Codezeilen und schreibe das auch nicht dran.
+
diff --git a/PKGBUILD b/PKGBUILD
index 4c0579f68d7b..962664568ffd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,16 @@
pkgname=redo-sh
_pkgname=redo
pkgver=1.1.6
-pkgrel=1
+pkgrel=2
pkgdesc="Redo implementation in Bourne Shell."
arch=("any")
-license=("GPL")
+license=("custom:AGPL")
url="http://news.dieweltistgarnichtso.net/bin/redo-sh.html"
-depends=("bash")
+depends=("sh")
conflicts=("redo-c-git" "redo-git")
-source=("http://daten.dieweltistgarnichtso.net/src/${_pkgname}-v${pkgver}.tar.gz")
-sha256sums=('68577c4e97b3707ab23999fa5d8886cbd509ea528a5becb40a8cc34528d7e8f5')
+source=("http://daten.dieweltistgarnichtso.net/src/${_pkgname}-v${pkgver}.tar.gz" "LICENSE")
+sha256sums=('68577c4e97b3707ab23999fa5d8886cbd509ea528a5becb40a8cc34528d7e8f5'
+ 'a864db46c8406508b3cea76ab86431c56b553bac67a9df22614c3cf1dd7e734b')
package() {
mkdir -p ${pkgdir}/usr/bin
@@ -19,5 +20,7 @@ package() {
mkdir -p ${pkgdir}/usr/share/man/man1
install -Dm644 man/man1/* "${pkgdir}/usr/share/man/man1/"
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}