summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--redshift-qt.desktop9
3 files changed, 9 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ef60c9b3f91..f3085d4cdb1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = redshift-qt-git
pkgdesc = redshift-gtk rewrite with C++/Qt (latest commit)
pkgver = 0.6.r0.g6724a9f
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Chemrat/redshift-qt
arch = x86_64
arch = i686
@@ -12,8 +12,6 @@ pkgbase = redshift-qt-git
provides = redshift-qt
conflicts = redshift-qt
source = git+https://github.com/Chemrat/redshift-qt.git
- source = redshift-qt.desktop
md5sums = SKIP
- md5sums = 9ef24b824bcfb46dbd951074af074772
pkgname = redshift-qt-git
diff --git a/PKGBUILD b/PKGBUILD
index de33efce4336..3d09dc2c9bd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=redshift-qt
pkgname=$_pkgname-git
pkgver=0.6.r0.g6724a9f
-pkgrel=1
+pkgrel=2
pkgdesc="redshift-gtk rewrite with C++/Qt (latest commit)"
arch=('x86_64' 'i686')
url="https://github.com/Chemrat/redshift-qt"
@@ -13,16 +13,18 @@ depends=('qt5-base' 'redshift')
makedepends=('git')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git+$url.git"
- "$_pkgname.desktop")
-md5sums=('SKIP'
- '9ef24b824bcfb46dbd951074af074772')
+source=("git+$url.git")
+md5sums=('SKIP')
pkgver() {
cd $_pkgname
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ sed -i -E "s|Name=Redshift|Name=Redshift Qt|g" $_pkgname/data/$_pkgname.desktop
+}
+
build() {
cd $_pkgname
qmake $_pkgname.pro
@@ -30,8 +32,8 @@ build() {
}
package() {
- install -Dm644 $_pkgname.desktop -t "$pkgdir/usr/share/applications"
cd $_pkgname
+ install -Dm644 data/$_pkgname.desktop -t "$pkgdir/usr/share/applications"
install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$_pkgname"
install -Dm755 $_pkgname -t "$pkgdir/usr/bin"
}
diff --git a/redshift-qt.desktop b/redshift-qt.desktop
deleted file mode 100644
index 40f8417b8f70..000000000000
--- a/redshift-qt.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Name=Redshift Qt
-Comment=Color temperature adjustment
-Exec=redshift-qt
-Terminal=false
-Type=Application
-StartupNotify=true
-Icon=redshift
-Categories=Utility;