summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD44
-rw-r--r--redshift-qt.desktop9
3 files changed, 26 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43673ac630e1..f3085d4cdb1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,17 @@
-# Generated by mksrcinfo v8
-# Sun Oct 9 19:14:32 UTC 2016
pkgbase = redshift-qt-git
- pkgdesc = redshift-gtk rewrite with C++/Qt
- pkgver = 0.2.r10.g20f92c3
- pkgrel = 1
+ pkgdesc = redshift-gtk rewrite with C++/Qt (latest commit)
+ pkgver = 0.6.r0.g6724a9f
+ pkgrel = 2
url = https://github.com/Chemrat/redshift-qt
arch = x86_64
arch = i686
license = MIT
makedepends = git
- depends = redshift
depends = qt5-base
+ depends = redshift
provides = redshift-qt
conflicts = redshift-qt
source = git+https://github.com/Chemrat/redshift-qt.git
- source = redshift-qt.desktop
md5sums = SKIP
- md5sums = 9ef24b824bcfb46dbd951074af074772
pkgname = redshift-qt-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 987afcdeac68..3d09dc2c9bd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,39 @@
-# Maintainer: Luca Weiss <WEI16416 (at) spengergasse (dot) at>
+# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
+# Contributor: Luca Weiss <luca (at) z3ntu (dot) xyz>
-pkgname=redshift-qt-git
_pkgname=redshift-qt
-pkgver=0.2.r10.g20f92c3
-pkgrel=1
-pkgdesc="redshift-gtk rewrite with C++/Qt"
+pkgname=$_pkgname-git
+pkgver=0.6.r0.g6724a9f
+pkgrel=2
+pkgdesc="redshift-gtk rewrite with C++/Qt (latest commit)"
arch=('x86_64' 'i686')
url="https://github.com/Chemrat/redshift-qt"
license=('MIT')
-depends=('redshift' 'qt5-base')
+depends=('qt5-base' 'redshift')
makedepends=('git')
-optdepends=()
-provides=('redshift-qt')
-conflicts=('redshift-qt')
-source=("git+https://github.com/Chemrat/redshift-qt.git"
- "redshift-qt.desktop")
-md5sums=('SKIP'
- '9ef24b824bcfb46dbd951074af074772')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url.git")
+md5sums=('SKIP')
pkgver() {
- cd "$_pkgname"
+ cd $_pkgname
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ sed -i -E "s|Name=Redshift|Name=Redshift Qt|g" $_pkgname/data/$_pkgname.desktop
+}
+
build() {
- cd "$_pkgname"
- qmake redshift-qt.pro
+ cd $_pkgname
+ qmake $_pkgname.pro
make
}
package() {
- cd "$_pkgname"
- install -Dm755 redshift-qt $pkgdir/usr/bin/redshift-qt
- install -Dm644 $srcdir/redshift-qt.desktop $pkgdir/usr/share/applications/redshift-qt.desktop
- install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
+ cd $_pkgname
+ install -Dm644 data/$_pkgname.desktop -t "$pkgdir/usr/share/applications"
+ install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$_pkgname"
+ install -Dm755 $_pkgname -t "$pkgdir/usr/bin"
}
-
-# vim:set ts=2 sw=2 et:
diff --git a/redshift-qt.desktop b/redshift-qt.desktop
deleted file mode 100644
index 40f8417b8f70..000000000000
--- a/redshift-qt.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Name=Redshift Qt
-Comment=Color temperature adjustment
-Exec=redshift-qt
-Terminal=false
-Type=Application
-StartupNotify=true
-Icon=redshift
-Categories=Utility;