summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD36
2 files changed, 20 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43673ac630e1..8ef60c9b3f91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
-# Generated by mksrcinfo v8
-# Sun Oct 9 19:14:32 UTC 2016
pkgbase = redshift-qt-git
- pkgdesc = redshift-gtk rewrite with C++/Qt
- pkgver = 0.2.r10.g20f92c3
+ pkgdesc = redshift-gtk rewrite with C++/Qt (latest commit)
+ pkgver = 0.6.r0.g6724a9f
pkgrel = 1
url = https://github.com/Chemrat/redshift-qt
arch = x86_64
arch = i686
license = MIT
makedepends = git
- depends = redshift
depends = qt5-base
+ depends = redshift
provides = redshift-qt
conflicts = redshift-qt
source = git+https://github.com/Chemrat/redshift-qt.git
@@ -19,4 +17,3 @@ pkgbase = redshift-qt-git
md5sums = 9ef24b824bcfb46dbd951074af074772
pkgname = redshift-qt-git
-
diff --git a/PKGBUILD b/PKGBUILD
index e72ba46ca9b6..de33efce4336 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,37 @@
-# Maintainer: Luca Weiss <luca (at) z3ntu (dot) xyz>
+# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
+# Contributor: Luca Weiss <luca (at) z3ntu (dot) xyz>
-pkgname=redshift-qt-git
_pkgname=redshift-qt
-pkgver=0.2.r10.g20f92c3
+pkgname=$_pkgname-git
+pkgver=0.6.r0.g6724a9f
pkgrel=1
-pkgdesc="redshift-gtk rewrite with C++/Qt"
+pkgdesc="redshift-gtk rewrite with C++/Qt (latest commit)"
arch=('x86_64' 'i686')
url="https://github.com/Chemrat/redshift-qt"
license=('MIT')
-depends=('redshift' 'qt5-base')
+depends=('qt5-base' 'redshift')
makedepends=('git')
-optdepends=()
-provides=('redshift-qt')
-conflicts=('redshift-qt')
-source=("git+https://github.com/Chemrat/redshift-qt.git"
- "redshift-qt.desktop")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url.git"
+ "$_pkgname.desktop")
md5sums=('SKIP'
'9ef24b824bcfb46dbd951074af074772')
pkgver() {
- cd "$_pkgname"
+ cd $_pkgname
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$_pkgname"
- qmake redshift-qt.pro
+ cd $_pkgname
+ qmake $_pkgname.pro
make
}
package() {
- cd "$_pkgname"
- install -Dm755 redshift-qt $pkgdir/usr/bin/redshift-qt
- install -Dm644 $srcdir/redshift-qt.desktop $pkgdir/usr/share/applications/redshift-qt.desktop
- install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
+ install -Dm644 $_pkgname.desktop -t "$pkgdir/usr/share/applications"
+ cd $_pkgname
+ install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$_pkgname"
+ install -Dm755 $_pkgname -t "$pkgdir/usr/bin"
}
-
-# vim:set ts=2 sw=2 et: