summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
-rw-r--r--redshift-qt.desktop9
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d60ccaae8d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sun Oct 9 19:06:10 UTC 2016
+pkgbase = redshift-qt-git
+ pkgdesc = redshift-gtk rewrite with C++/Qt
+ pkgver = 0.2.r10.g20f92c3
+ pkgrel = 1
+ url = https://github.com/Chemrat/redshift-qt
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = qt5-base
+ depends = redshift
+ provides = redshift-qt
+ conflicts = redshift-qt
+ source = git+https://github.com/Chemrat/redshift-qt.git
+ source = redshift-qt.desktop
+ md5sums = SKIP
+ md5sums = 9ef24b824bcfb46dbd951074af074772
+
+pkgname = redshift-qt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2dda8fcc6ba4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Luca Weiss <WEI16416 (at) spengergasse (dot) at>
+
+pkgname=redshift-qt-git
+_pkgname=redshift-qt
+pkgver=0.2.r10.g20f92c3
+pkgrel=1
+pkgdesc="redshift-gtk rewrite with C++/Qt"
+arch=('x86_64' 'i686')
+url="https://github.com/Chemrat/redshift-qt"
+license=('MIT')
+depends=('redshift')
+makedepends=('qt5-base')
+optdepends=()
+provides=('redshift-qt')
+conflicts=('redshift-qt')
+source=("git+https://github.com/Chemrat/redshift-qt.git"
+ "redshift-qt.desktop")
+md5sums=('SKIP'
+ '9ef24b824bcfb46dbd951074af074772')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+ qmake redshift-qt.pro
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm755 redshift-qt $pkgdir/usr/bin/redshift-qt
+ install -Dm644 $srcdir/redshift-qt.desktop $pkgdir/usr/share/applications/redshift-qt.desktop
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/redshift-qt.desktop b/redshift-qt.desktop
new file mode 100644
index 000000000000..40f8417b8f70
--- /dev/null
+++ b/redshift-qt.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Redshift Qt
+Comment=Color temperature adjustment
+Exec=redshift-qt
+Terminal=false
+Type=Application
+StartupNotify=true
+Icon=redshift
+Categories=Utility;