summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--refind-theme-matrix.install6
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77845a9abe28
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = refind-theme-matrix-git
+ pkgdesc = Matrix-inspired rEFInd theme depicting Morpheus offering two choices
+ pkgver = r19.91e3823
+ pkgrel = 1
+ url = https://github.com/Yannis4444/Matrix-rEFInd
+ install = refind-theme-matrix.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = refind
+ backup = boot/EFI/refind/themes/Matrix-rEFInd/theme.conf
+ source = git+https://github.com/Yannis4444/Matrix-rEFInd.git
+ md5sums = SKIP
+
+pkgname = refind-theme-matrix-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6438578cffd2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jan Sonntag <jaso35 at googlemail dot com>
+pkgname=refind-theme-matrix-git
+pkgver=r19.91e3823
+pkgrel=1
+pkgdesc="Matrix-inspired rEFInd theme depicting Morpheus offering two choices"
+arch=('any')
+url="https://github.com/Yannis4444/Matrix-rEFInd"
+license=('MIT')
+depends=('refind')
+makedepends=('git')
+backup=(boot/EFI/refind/themes/Matrix-rEFInd/theme.conf)
+source=('git+https://github.com/Yannis4444/Matrix-rEFInd.git')
+install=refind-theme-matrix.install
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/Matrix-rEFInd"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ _refind_home="${pkgdir}/boot/EFI/refind"
+
+ mkdir -p "$_refind_home"/themes/Matrix-rEFInd
+ cp -r "$srcdir"/Matrix-rEFInd/* "$_refind_home"/themes/Matrix-rEFInd/
+ rm "$_refind_home"/themes/Matrix-rEFInd/{preview.jpg,README.md,LICENSE.md}
+ chmod -R 644 "$_refind_home"/themes/Matrix-rEFInd/
+}
diff --git a/refind-theme-matrix.install b/refind-theme-matrix.install
new file mode 100644
index 000000000000..252b01029df1
--- /dev/null
+++ b/refind-theme-matrix.install
@@ -0,0 +1,6 @@
+post_install() {
+ echo 'Remember to add "include themes/Matrix-rEFInd/theme.conf" to your refind.conf file'
+}
+post_remove() {
+ echo 'Remember to remove "include themes/Matrix-rEFInd/theme.conf" from your refind.conf file'
+}