summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b023a4fee93a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = reicast-git
+ pkgdesc = A multiplatform Sega Dreamcast emulator (development version)
+ pkgver = r791.823cd76
+ pkgrel = 1
+ url = http://reicast.com/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = BSD
+ license = MIT
+ makedepends = git
+ depends = lib32-libgl
+ depends = lib32-alsa-lib
+ provides = reicast
+ conflicts = reicast
+ source = reicast::git+https://github.com/reicast/reicast-emulator.git
+ md5sums = SKIP
+
+pkgname = reicast-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56126e247b07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+
+pkgname=reicast-git
+pkgver=r791.823cd76
+pkgrel=1
+pkgdesc="A multiplatform Sega Dreamcast emulator (development version)"
+arch=('i686' 'x86_64')
+url="http://reicast.com/"
+license=('GPL2' 'BSD' 'MIT')
+conflicts=('reicast')
+provides=('reicast')
+makedepends=('git')
+depends=('lib32-libgl' 'lib32-alsa-lib')
+[ "$CARCH" == "i686" ] && depends=('libgl' 'alsa-lib')
+source=(reicast::"git+https://github.com/reicast/reicast-emulator.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd reicast
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build () {
+ make -C reicast/shell/lin86
+}
+
+package () {
+ cd reicast
+
+ install -Dm755 shell/lin86/reicast.elf "$pkgdir"/usr/bin/reicast
+ # license
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}