summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD13
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22783949f83a..40ebcf742790 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = reicast-git
pkgdesc = A multiplatform Sega Dreamcast emulator (development version)
- pkgver = r1284.d3c3feb
+ pkgver = r1633.1a751e3
pkgrel = 1
url = http://reicast.com/
arch = i686
arch = x86_64
+ arch = armv7h
license = GPL2
license = BSD
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index f4510f28c847..9e074a7b9fd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributor: Holzhaus <jan.holthuis@ruhr-uni-bochum.de>
pkgname=reicast-git
-pkgver=r1284.d3c3feb
+pkgver=r1633.1a751e3
pkgrel=1
pkgdesc="A multiplatform Sega Dreamcast emulator (development version)"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'armv7h')
url="http://reicast.com/"
license=('GPL2' 'BSD' 'MIT')
conflicts=('reicast')
@@ -20,13 +21,9 @@ pkgver() {
}
build () {
- make -C reicast/shell/linux
+ make -C reicast/shell/linux PREFIX=/usr
}
package () {
- cd reicast
-
- install -Dm755 shell/linux/reicast.elf "$pkgdir"/usr/bin/reicast
- # license
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ make -C reicast/shell/linux DESTDIR="$pkgdir/" PREFIX=/usr install
}