summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d494f8b74dd..a311d0fcfb7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,24 @@
pkgbase = remacs-git
pkgdesc = Development branch of REmacs, a fork of GNU Emacs with components rewritten in Rust
- pkgver = 26.0.60.132231
+ pkgver = 26.2.90.135291
pkgrel = 1
- url = https://github.com/Wilfred/remacs.git
+ url = https://github.com/remacs/remacs.git
arch = i686
arch = x86_64
+ arch = aarch64
license = GPL
makedepends = git
- makedepends = cargo
+ makedepends = clang
+ makedepends = rustup
depends = gpm
depends = m17n-lib
depends = alsa-lib
depends = imagemagick
depends = gtk3
depends = giflib
- source = remacs-git::git+https://github.com/Wilfred/remacs.git
+ provides = remacs
+ conflicts = remacs
+ source = remacs-git::git+https://github.com/remacs/remacs.git
md5sums = SKIP
pkgname = remacs-git
diff --git a/PKGBUILD b/PKGBUILD
index d4f47cfd0a74..30c083793491 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -46,14 +46,16 @@ DOCS_INFO="NO" # Generate and install GNU info documentation.
#######################################################################
pkgname=remacs-git
-pkgver=26.0.60.132231
+pkgver=26.2.90.135291
pkgrel=1
pkgdesc="Development branch of REmacs, a fork of GNU Emacs with components rewritten in Rust"
-arch=('i686' 'x86_64')
-url="https://github.com/Wilfred/remacs.git"
+arch=('i686' 'x86_64' 'aarch64')
+url="https://github.com/remacs/remacs.git"
license=('GPL')
depends=('gpm' 'm17n-lib' 'alsa-lib' 'imagemagick')
-makedepends=('git' 'cargo')
+makedepends=('git' 'clang' 'rustup')
+provides=('remacs')
+conflicts=('remacs')
#######################################################################
#######################################################################
if [[ $GTK2 = "YES" ]]; then
@@ -78,7 +80,7 @@ fi
if [[ $DOCS_PDF = "YES" ]]; then makedepends+=('texlive-core'); fi
#######################################################################
#######################################################################
-source=("$pkgname::git+https://github.com/Wilfred/remacs.git")
+source=("$pkgname::git+https://github.com/remacs/remacs.git")
md5sums=('SKIP')
pkgver() {
@@ -94,7 +96,7 @@ pkgver() {
# Doing so, breaks incremental compilation.
prepare() {
cd "$srcdir/$pkgname"
-
+ rustup show
[[ -x configure ]] || ./autogen.sh
}