summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--changelog4
3 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6a4102931a1..4ab00d538e54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = remakepkg
pkgdesc = Apply changes to pacman packages
- pkgver = 0.7.7
- pkgrel = 2
+ pkgver = 0.7.8
+ pkgrel = 1
url = https://gitlab.com/ayekat/pacman-hacks
changelog = changelog
arch = any
@@ -11,7 +11,7 @@ pkgbase = remakepkg
depends = coreutils
depends = sed
conflicts = makemetapkg
- source = git+https://gitlab.com/ayekat/pacman-hacks.git#tag=v0.7.7
+ source = git+https://gitlab.com/ayekat/pacman-hacks.git#tag=v0.7.8
source = diffrepo.hook.example
sha256sums = SKIP
sha256sums = 4b723cf33b30f6176f8f50623c2325d05d5dc70463ca2bcd893fae2ccab5776e
diff --git a/PKGBUILD b/PKGBUILD
index bc864d186d23..c53a3273de0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Tinu Weber <http://ayekat.ch>
pkgname=remakepkg
-pkgver=0.7.7
-pkgrel=2
+pkgver=0.7.8
+pkgrel=1
arch=(any)
pkgdesc='Apply changes to pacman packages'
@@ -28,6 +28,7 @@ _tools='diffrepo getpkg pkgmirror remakepkg repkg'
build() {
cd pacman-hacks
+ make clean
make PREFIX=/usr SCRIPTS="$_tools" MANPAGES="$_tools"
}
@@ -35,7 +36,12 @@ package() {
depends+=(bash curl expac grep gzip fakeroot libarchive pacman sh vi)
cd pacman-hacks
- make DESTDIR="$pkgdir" SCRIPTS="$_tools" MANPAGES="$_tools" install
+ make \
+ PREFIX=/usr \
+ DESTDIR="$pkgdir" \
+ SCRIPTS="$_tools" \
+ MANPAGES="$_tools" \
+ install
install -Dm 0644 README "$pkgdir"/usr/share/doc/remakepkg/README
install -Dm 0644 CHANGELOG "$pkgdir"/usr/share/doc/remakepkg/CHANGELOG
install -Dm 0644 "$srcdir"/diffrepo.hook.example \
diff --git a/changelog b/changelog
index e74919b1dac4..26879dffbcca 100644
--- a/changelog
+++ b/changelog
@@ -1,3 +1,7 @@
+v0.7.8-1 (2019-05-13)
+* Makefile: Fix target dependencies to allow multithreaded building
+* man pages: Clarify/improve some sections
+
v0.7.7-2 (2019-05-12)
* Add conflict with makemetapkg