summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD38
-rw-r--r--changelog102
-rw-r--r--diffrepo.hook.example13
5 files changed, 185 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ee06866074e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = remakepkg
+ pkgdesc = Apply changes to pacman packages
+ pkgver = 0.6.5
+ pkgrel = 1
+ url = https://gitlab.com/ayekat/pacman-hacks
+ arch = any
+ license = GPL3
+ makedepends = asciidoc
+ makedepends = git
+ depends = coreutils
+ source = git+https://gitlab.com/ayekat/pacman-hacks.git#tag=v0.6.5
+ source = diffrepo.hook.example
+ sha256sums = SKIP
+ sha256sums = 4b723cf33b30f6176f8f50623c2325d05d5dc70463ca2bcd893fae2ccab5776e
+
+pkgname = remakepkg
+ depends = coreutils
+ depends = bash
+ depends = curl
+ depends = expac
+ depends = grep
+ depends = gzip
+ depends = fakeroot
+ depends = libarchive
+ depends = pacman
+ depends = sed
+ depends = sh
+ depends = vi
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..366e1ae483c6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/pacman-hacks/
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8246ba2854cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Tinu Weber <http://ayekat.ch>
+
+pkgname=remakepkg
+pkgver=0.6.5
+pkgrel=1
+arch=(any)
+
+pkgdesc='Apply changes to pacman packages'
+url='https://gitlab.com/ayekat/pacman-hacks'
+license=(GPL3)
+
+depends=(coreutils)
+makedepends=(asciidoc git)
+
+source=("git+https://gitlab.com/ayekat/pacman-hacks.git#tag=v$pkgver"
+ 'diffrepo.hook.example')
+sha256sums=(SKIP
+ 4b723cf33b30f6176f8f50623c2325d05d5dc70463ca2bcd893fae2ccab5776e)
+
+build() {
+ cd pacman-hacks
+ make PREFIX=/usr
+}
+
+package() {
+ depends+=(bash curl expac grep gzip fakeroot libarchive pacman sed sh vi)
+
+ cd pacman-hacks
+ make \
+ DESTDIR="$pkgdir" \
+ SCRIPTS='diffrepo getpkg pkgmirror remakepkg repkg' \
+ MANPAGES='diffrepo getpkg pkgmirror remakepkg repkg' \
+ install
+ install -Dm 0644 README "$pkgdir"/usr/share/doc/remakepkg/README
+ install -Dm 0644 CHANGELOG "$pkgdir"/usr/share/doc/remakepkg/CHANGELOG
+ install -Dm 0644 "$srcdir"/diffrepo.hook.example \
+ "$pkgdir"/usr/share/doc/remakepkg/diffrepo.hook.example
+}
diff --git a/changelog b/changelog
new file mode 100644
index 000000000000..47eae1445095
--- /dev/null
+++ b/changelog
@@ -0,0 +1,102 @@
+v0.6.5-3 (2018-08-27)
+* pacman-hacks-build: Add versioned dependency on pacman-hacks
+* Add provides and conflicts for all included scripts
+
+v0.6.5-2 (2018-08-25)
+* Clean rebuild (for man pages)
+
+v0.6.5-1 (2018-08-22)
+* metapkg: Properly escape special characters in description strings
+
+v0.6.4-1 (2018-08-17)
+* metapkg: Properly generate conflicts/provides/replaces lines in PKGBUILD
+* metapkg: Fix output file location when being passed a relative path
+
+v0.6.3-1 (2018-08-07)
+* metapkg: Print info message for optional dependencies as well
+
+v0.6.2-1 (2018-06-24)
+* remakepkg: Add forgotten command line option -R
+
+v0.6.1-1 (2018-06-24)
+* remakepkg: Don't check for (wrong) output file existence
+
+v0.6-1 (2018-06-24)
+* metapkg: Add conflicts/provides/replaces
+* repkg: -o now takes an output *directory* (instead of output *filename*)
+* repkg: Packages now get a dotted suffix for the pkgrel
+* zr: Repository profiles are now read from $XDG_CONFIG_HOME/zr/repos
+* Bug fixes as in v0.5.1 and v0.5.2
+
+v0.5.2-1 (2018-06-24)
+* repkg: Fix error handling + file check that could lead to incomplete packages
+
+v0.5.1-4 (2018-06-14)
+* Remove unnecessary conflicts and provides
+
+v0.5.1-3 (2018-06-12)
+* Fix typo in install script
+
+v0.5.1-2 (2018-06-12)
+* Split build scripts into separate -build package
+
+v0.5.1-1 (2018-06-10)
+* pacred: Don't treat base-devel specially
+
+v0.5-1 (2018-04-16)
+* Add metapkg, a tool to generate meta-packages from compact rule files
+* Add makemetapkg, a wrapper around to build meta-packages using a METAPKGBUILD
+* Change project description a bit ("simplify" → "complement")
+* repkg: Drop functionality that reads rules from stdin (-r is now mandatory)
+* repkg: Add `add-group`/`remove-group`
+* diffrepo: Add -n to ignore/negate specific packages in a repository
+* Bug fixes as in v0.4.1 and v0.4.1.1
+
+v0.4.1.1-1 (2018-03-18)
+* Fix version information in help output and man pages
+
+v0.4.1-1 (2018-03-18)
+* Fix syntax error in library file
+* repkg: Handle spaces in XDG_CONFIG_HOME correctly
+
+v0.4-1 (2018-03-13)
+* Add remakepkg, a wrapper around repkg to repackage packages using a REPKGBUILD
+* repkg has a slightly different invocation syntax syntax now (more "low-level")
+* repkg: Add `set-arch` and `set-url` commands
+* repkg: Correctly update packager information
+* getpkg: Add -o option to specify output file
+* zr: Bulk-addition speed improved
+* Bug fixes as in v0.3.1, v0.3.2, v0.3.3 and v0.3.4
+
+v0.3.4-1 (2018-03-08)
+* zr: Don't print raw file names that are deleted
+
+v0.3.3-1 (2018-03-05)
+* zr: Correctly overwrite package in database as well if invoked with -f
+
+v0.3.2-1 (2018-03-03)
+* man pages: Use commit date, not build date
+
+v0.3.1-1 (2018-03-03)
+* repkg: Don't accept "empty command" or comment after a package name
+
+v0.3-1 (2018-02-26)
+* Add `-h` command line option (and help output) to all scripts
+* zr: Change argument format (`zr add package repo` and `zr rm repo/package`)
+* zr: Add `ls` subcommand
+* New scripts: diffrepo, getpkg, pkgmirror, repkg
+* Removed scripts: pacbloat
+* Bug fixes as in v0.2.1 and v0.2.2
+
+v0.2.2-1 (2018-02-12)
+* Project renamed from pacman-contrib-zuepfe to pacman-hacks
+
+v0.2.1-1 (2018-02-09)
+* zr: Fix argument handling
+
+v0.2-1 (2018-02-09)
+* Project renamed from zr to pacman-contrib-zuepfe
+* Add abs, ala, aur, checkrestart, pacbloat, pacred and pacwhy
+
+v0.1-1 (2017-12-16)
+* Initial release as zr
diff --git a/diffrepo.hook.example b/diffrepo.hook.example
new file mode 100644
index 000000000000..e266b248809e
--- /dev/null
+++ b/diffrepo.hook.example
@@ -0,0 +1,13 @@
+# Example hook for running diffrepo before each upgrade
+
+[Trigger]
+Operation = Upgrade
+Type = Package
+Target = *
+
+[Action]
+Description = Checking package version consistency for XYZ...
+When = PreTransaction
+AbortOnFail
+Depends = pacman-hacks
+Exec = /usr/bin/diffrepo -r -n ABC -s XYZ