summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 6 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff4ddbfaf840..3cfa1e9b09be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,6 +10,9 @@ pkgbase = repoctl-devel-git
makedepends = go
makedepends = git
depends = pacman
+ provides = repoctl
+ conflicts = repoctl
+ conflicts = repoctl-git
options = !strip
source = repoctl::git+https://github.com/cassava/repoctl.git#branch=devel
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b4b012f21988..ad8d691874d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,6 +15,8 @@ makedepends=('go' 'git')
options=('!strip')
source=("${_pkgname}::git+https://github.com/cassava/repoctl.git#branch=devel")
md5sums=('SKIP')
+provides=('repoctl')
+conflicts=('repoctl' 'repoctl-git')
pkgver() {
cd "${_pkgname}"
@@ -52,4 +54,4 @@ package() {
install -Dm644 contrib/repoctl_completion.bash "$pkgdir/usr/share/bash-completion/completions/repoctl"
}
-# vim: set ts=2 sw=2: \ No newline at end of file
+# vim: set ts=2 sw=2: