summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO34
-rw-r--r--LICENSE15
-rw-r--r--PKGBUILD50
3 files changed, 58 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c7647fd9d6e..7163ef8abf1f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
-# Generated by mksrcinfo v8
-# Sun May 8 18:47:13 UTC 2016
pkgbase = reportbug
- pkgdesc = report bugs in the Debian distribution + python modules
- pkgver = 6.6.6
- pkgrel = 2
- url = http://packages.debian.org/sid/reportbug
+ pkgdesc = A tool designed to make the reporting of bugs in Debian and derived distributions relatively painless
+ pkgver = 13.0.1
+ pkgrel = 1
+ url = https://salsa.debian.org/reportbug-team/reportbug
arch = any
- license = MIT
- depends = python2-debian
- depends = python2-debianbts
+ license = custom
+ makedepends = python-setuptools
+ depends = python
+ depends = python-debian
+ depends = python-debianbts
+ depends = python-apt
depends = apt
- depends = sensible-utils
- provides = python2-reportbug=6.6.6
- conflicts = python2-reportbug
- options = !emptydirs
- backup = etc/reportbug.conf
- source = http://ftp.debian.org/debian/pool/main/r/reportbug/reportbug_6.6.6.tar.bz2
- sha256sums = d9667bde27f8a275a96c200dd7492fd4318ca3924c86abcd4413d95eb2261e35
+ optdepends = sensible-utils: default editor
+ provides = python-reportbug
+ conflicts = python-reportbug
+ source = https://salsa.debian.org/reportbug-team/reportbug/-/archive/13.0.1/reportbug-13.0.1.tar.gz
+ source = LICENSE
+ sha256sums = 8485ee073ffb04cf7476ceb289d5b60f0b230ee22aa4256b04de6b3df04e402f
+ sha256sums = 604ec308937cc86922cd5c64baaf0e63ccbc87b8d8d3a6c1c5b0f2e47182b273
pkgname = reportbug
-
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..b89fd5b49b5a
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,15 @@
+This program is freely distributable per the following license:
+
+Permission to use, copy, modify, and distribute this software and its
+documentation for any purpose and without fee is hereby granted,
+provided that the above copyright notice appears in all copies and that
+both that copyright notice and this permission notice appear in
+supporting documentation.
+
+I DISCLAIM ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL I
+BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY
+DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS,
+WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION,
+ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index cb429888d817..49e30e5dc2c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,34 @@
-# Contributor: Johannes Dewender arch at JonnyJD dot net
+# Maintainer: Ben Westover <kwestover.kw@gmail.com>
+
pkgname=reportbug
-pkgver=6.6.6
-pkgrel=2
-pkgdesc="report bugs in the Debian distribution + python modules"
+pkgver=13.0.1
+pkgrel=1
+pkgdesc="A tool designed to make the reporting of bugs in Debian and derived distributions relatively painless"
arch=('any')
-url="http://packages.debian.org/sid/reportbug"
-license=('MIT')
-depends=('python2-debian' 'python2-debianbts' 'apt'
-'sensible-utils')
-provides=("python2-reportbug=$pkgver")
-conflicts=('python2-reportbug')
-options=(!emptydirs)
-backup=('etc/reportbug.conf')
-source=(http://ftp.debian.org/debian/pool/main/r/$pkgname/${pkgname}_$pkgver.tar.bz2)
-sha256sums=('d9667bde27f8a275a96c200dd7492fd4318ca3924c86abcd4413d95eb2261e35')
+url="https://salsa.debian.org/reportbug-team/reportbug"
+license=('custom')
+depends=('python' 'python-debian' 'python-debianbts' 'python-apt' 'apt')
+makedepends=('python-setuptools')
+optdepends=('sensible-utils: default editor')
+conflicts=('python-reportbug')
+provides=('python-reportbug')
+source=("https://salsa.debian.org/$pkgname-team/$pkgname/-/archive/$pkgver/$pkgname-${pkgver}.tar.gz"
+ "LICENSE" # Extracted from debian/copyright in the source tree
+ )
+sha256sums=('8485ee073ffb04cf7476ceb289d5b60f0b230ee22aa4256b04de6b3df04e402f'
+ '604ec308937cc86922cd5c64baaf0e63ccbc87b8d8d3a6c1c5b0f2e47182b273')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- python2 setup.py build
+ cd $pkgname-$pkgver
+ python setup.py build
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- python2 setup.py install --root="$pkgdir/" --optimize=1
- mkdir -p $pkgdir/usr/share/man/man1/ $pkgdir/usr/share/man/man5/
- install -m644 -t $pkgdir/usr/share/man/man1/ man/*.1
- install -m644 -t $pkgdir/usr/share/man/man5/ man/*.5
- install -Dm644 conf/reportbug.conf $pkgdir/etc/reportbug.conf
+ cd $pkgname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ mkdir -p $pkgdir/usr/share/man/man1 $pkgdir/usr/share/man/man5
+ install -m644 -t $pkgdir/usr/share/man/man1/ man/*.1
+ install -m644 -t $pkgdir/usr/share/man/man5/ man/*.5
+ install -Dm644 conf/reportbug.conf $pkgdir/etc/reportbug.conf
+ install -Dm644 $srcdir/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}
-
-# vim:set ts=2 sw=2 et: