summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 42c44358e389..e049b0502ebf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
-# Generated by mksrcinfo v8
-# Sun Jun 17 07:55:07 UTC 2018
pkgbase = restic-git
pkgdesc = restic is a program that does backups right.
- pkgver = v0.9.1.r12.g1824168a
+ pkgver = 0.11.0.r189.ge96677ca
pkgrel = 1
url = https://github.com/restic/restic
arch = i686
arch = x86_64
license = BSD
makedepends = git
- makedepends = go>=1.3
+ makedepends = go
depends = glibc
provides = restic
conflicts = restic
diff --git a/PKGBUILD b/PKGBUILD
index 280b19bdaf28..ee577c1e63ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
# Contributor: Alexander Neumann <alexander@bumpern.de>
options=(!strip)
pkgname=restic-git
-pkgver=v0.9.1.r12.g1824168a
+pkgver=0.11.0.r189.ge96677ca
pkgrel=1
pkgdesc="restic is a program that does backups right."
arch=('i686' 'x86_64')
url="https://github.com/restic/restic"
license=('BSD')
depends=('glibc')
-makedepends=('git' 'go>=1.3')
+makedepends=('git' 'go')
provides=('restic')
conflicts=('restic')
source=("${pkgname}::git+https://github.com/restic/restic")
@@ -21,7 +21,7 @@ importpath='github.com/restic/restic'
pkgver() {
cd "$pkgname"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -33,7 +33,7 @@ build() {
package() {
install -Dm755 "$pkgname/restic" "$pkgdir/usr/bin/restic"
install -Dm644 "$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 "$pkgname/README.rst" "$pkgdir/usr/share/doc/$pkgname/README"
+ install -Dm644 "$pkgname/README.md" "$pkgdir/usr/share/doc/$pkgname/README"
install -Dm644 -t "$pkgdir/usr/share/man/man1" "$pkgname"/doc/man/*.1
}