summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore1
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD26
4 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e1538745f1f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = restream-git
+ pkgdesc = Shell script for sharing the reMarkable's screen over SSH.
+ pkgver = r45.220d387
+ pkgrel = 1
+ url = https://github.com/rien/reStream
+ arch = any
+ license = MIT
+ depends = openssh
+ depends = ffmpeg
+ optdepends = lz4: sub-second latency streaming (see README)
+ optdepends = v4l2loopback-dkms: stream reMarkable as a webcam
+ provides = restream
+ conflicts = restream
+ source = git+https://github.com/rien/reStream.git
+ md5sums = SKIP
+
+pkgname = restream-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..328140490039
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2020 Rien Maertens <Rien.Maertens@posteo.be>
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..826cd21e1168
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Gustavo Jasso <gustavo at jasso dot info>
+_pkgname='reStream'
+pkgname=$(echo "$_pkgname-git" | tr '[:upper:]' '[:lower:]')
+pkgdesc="Shell script for sharing the reMarkable's screen over SSH."
+pkgver=r45.220d387
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+pkgrel=1
+url="https://github.com/rien/reStream"
+arch=('any')
+license=('MIT')
+depends=('openssh' 'ffmpeg')
+optdepends=('lz4: sub-second latency streaming (see README)' 'v4l2loopback-dkms: stream reMarkable as a webcam')
+source=("git+https://github.com/rien/reStream.git")
+md5sums=('SKIP')
+conflicts=('restream')
+provides=('restream')
+
+package() {
+ install -Dm644 "$startdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir/$_pkgname/README.md" "$pkgdir/usr/share/$pkgname/README.md"
+ install -Dm644 "$srcdir/$_pkgname/extra/demo.gif" "$pkgdir/usr/share/$pkgname/extra/demo.gif"
+ install -Dm755 $srcdir/$_pkgname/reStream.sh $pkgdir/usr/bin/restream
+}