summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..801c12a8c87f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ret-sync-gdb-git
+ pkgdesc = Set of plugins that help to synchronize a debugging session with a disassembler - GDB plugin
+ pkgver = r54.ba51775
+ pkgrel = 1
+ url = https://github.com/bootleg/ret-sync
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = gdb
+ optdepends = ret-sync-ghidra: Ghidra integration
+ provides = ret-sync-gdb
+ conflicts = ret-sync-gdb
+ source = git+https://github.com/bootleg/ret-sync
+ md5sums = SKIP
+
+pkgname = ret-sync-gdb-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..66663c8a3516
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+ret-sync/
+*.pkg*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..604ef7f4e262
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: gmes78 <gmes.078 at gmail dot com>
+
+pkgname=ret-sync-gdb-git
+pkgver=r54.ba51775
+pkgrel=1
+pkgdesc="Set of plugins that help to synchronize a debugging session with a disassembler - GDB plugin"
+arch=(any)
+url="https://github.com/bootleg/ret-sync"
+license=('GPL')
+provides=('ret-sync-gdb')
+conflicts=('ret-sync-gdb')
+
+depends=('gdb')
+makedepends=('git')
+optdepends=('ret-sync-ghidra: Ghidra integration')
+
+source=('git+https://github.com/bootleg/ret-sync')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/ret-sync"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/ret-sync/ext_gdb"
+ install -D -m644 sync.py "$pkgdir/usr/share/retsync/sync.py"
+}