summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD19
3 files changed, 12 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54b5cdbe0d26..7c007239681c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rethinkdb
pkgdesc = Distributed NoSQL database for realtime applications
- pkgver = 2.4.2
- pkgrel = 2
+ pkgver = 2.4.4
+ pkgrel = 1
url = https://www.rethinkdb.com
install = rethinkdb.install
arch = x86_64
@@ -14,21 +14,16 @@ pkgbase = rethinkdb
depends = curl
depends = jemalloc
depends = openssl
- depends = protobuf
depends = zlib
options = !emptydirs
backup = etc/rethinkdb/instances.d/default.conf
- source = https://github.com/rethinkdb/rethinkdb/archive/refs/tags/v2.4.2.tar.gz
+ source = rethinkdb-2.4.4.tar.gz::https://github.com/rethinkdb/rethinkdb/archive/refs/tags/v2.4.4.tar.gz
source = rethinkdb@.service
source = rethinkdb.sysusers.d
source = rethinkdb.tmpfiles.d
- source = fix1.patch::https://github.com/rethinkdb/rethinkdb/commit/9ab11f5c9aef0a9d14b92aefd1defa07ad27049e.patch
- source = fix2.patch::https://github.com/rethinkdb/rethinkdb/commit/0d504ef964cb5f86aa90afe396d701707dd130e7.patch
- sha512sums = afb01bd273f7ec76e96db9af601467ed63131e1078647e80ea4bec3f026f86e2d3c7614634db4d504cc6f6e9251ab1a1c8bf3b4130ef921b0960b00c76740542
+ sha512sums = 4a2f825da9b676e924a9aa9c366213cfe782b2816c52bcfdd200d9c391961c2e96cdbfd2dd339d3b4602f9fb6c819bec5c0c7f2834037a1d6680e59bb4bbf5b5
sha512sums = d0e86e86010fafcfdad7a58fe9ed9e93deefb1ab803aa283f60cccaf7a0ee11990c59b9ab01872b1c97b08418d7b53064e938b428e50a310442b32aa385277d9
sha512sums = cab680a7e765e0a844b72ab3a57f19f3268d9a717bbe19230bd79537f0424179a56037c368326d2173a4a9cde075a67c85ce9b5a32733afb7d44806df1eac0ac
sha512sums = 112bc0f9ecfdfae6efba5d8cc3f773085b3f345d33d350188dc70609c425e6c656a0a3069ae5c66cdc684a94fd442e990a88c0ca8d1875f085f660c76c3d7250
- sha512sums = da3c2ec3366df96d6d78ae2e66bfd6c0192574a23f5a7b351aea4c7eb78009226ee3c194c00f636fcee48b8a730cc246d57c27a8bf425c1f47475b07b5525a91
- sha512sums = 48faf503ab6b93cca7f2c3e531b41115b57bff50183f6753d0bc3f21214178164c510a7974ad4205634dcb4da0434ce4aac5ddabe671349686c25c2e87968be1
pkgname = rethinkdb
diff --git a/.gitignore b/.gitignore
index 345106de096a..d163ed37b48d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,4 +5,4 @@ rethinkdb/
node-v6.11.0.tar.gz
v8_g++7_build_fix.patch
fix*.patch
-v*.tar.gz
+rethinkdb-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 8ddb673f9435..324639850755 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,39 +5,33 @@
# Contributor: Sigmund Lahn <sigmund@lahn.no>
pkgname=rethinkdb
-pkgver=2.4.2
-pkgrel=2
+pkgver=2.4.4
+pkgrel=1
pkgdesc='Distributed NoSQL database for realtime applications'
arch=(x86_64)
url=https://www.rethinkdb.com
license=(Apache)
-depends=(curl jemalloc openssl protobuf zlib)
+depends=(curl jemalloc openssl zlib)
makedepends=(clang git python make boost)
backup=(etc/rethinkdb/instances.d/default.conf)
install=rethinkdb.install
options=(!emptydirs)
source=(
- https://github.com/rethinkdb/rethinkdb/archive/refs/tags/v2.4.2.tar.gz
+ $pkgname-$pkgver.tar.gz::https://github.com/rethinkdb/rethinkdb/archive/refs/tags/v${pkgver}.tar.gz
rethinkdb@.service
rethinkdb.sysusers.d
rethinkdb.tmpfiles.d
- fix1.patch::https://github.com/rethinkdb/rethinkdb/commit/9ab11f5c9aef0a9d14b92aefd1defa07ad27049e.patch
- fix2.patch::https://github.com/rethinkdb/rethinkdb/commit/0d504ef964cb5f86aa90afe396d701707dd130e7.patch
)
-sha512sums=('afb01bd273f7ec76e96db9af601467ed63131e1078647e80ea4bec3f026f86e2d3c7614634db4d504cc6f6e9251ab1a1c8bf3b4130ef921b0960b00c76740542'
+sha512sums=('4a2f825da9b676e924a9aa9c366213cfe782b2816c52bcfdd200d9c391961c2e96cdbfd2dd339d3b4602f9fb6c819bec5c0c7f2834037a1d6680e59bb4bbf5b5'
'd0e86e86010fafcfdad7a58fe9ed9e93deefb1ab803aa283f60cccaf7a0ee11990c59b9ab01872b1c97b08418d7b53064e938b428e50a310442b32aa385277d9'
'cab680a7e765e0a844b72ab3a57f19f3268d9a717bbe19230bd79537f0424179a56037c368326d2173a4a9cde075a67c85ce9b5a32733afb7d44806df1eac0ac'
- '112bc0f9ecfdfae6efba5d8cc3f773085b3f345d33d350188dc70609c425e6c656a0a3069ae5c66cdc684a94fd442e990a88c0ca8d1875f085f660c76c3d7250'
- 'da3c2ec3366df96d6d78ae2e66bfd6c0192574a23f5a7b351aea4c7eb78009226ee3c194c00f636fcee48b8a730cc246d57c27a8bf425c1f47475b07b5525a91'
- '48faf503ab6b93cca7f2c3e531b41115b57bff50183f6753d0bc3f21214178164c510a7974ad4205634dcb4da0434ce4aac5ddabe671349686c25c2e87968be1')
+ '112bc0f9ecfdfae6efba5d8cc3f773085b3f345d33d350188dc70609c425e6c656a0a3069ae5c66cdc684a94fd442e990a88c0ca8d1875f085f660c76c3d7250')
prepare() {
# There are a ton of hard dependencies on Python 2
# Let's KISS and pretend `python` points to Python 2
cd $pkgname-$pkgver
- patch -p1 < "$srcdir"/fix1.patch
- patch -p1 < "$srcdir"/fix2.patch
echo $pkgver > VERSION
PATH="$srcdir"/bin:$PATH ./configure \
@@ -45,6 +39,7 @@ prepare() {
--sysconfdir=/etc \
--localstatedir=/var \
--dynamic jemalloc \
+ --fetch protoc \
CXX=clang++
}