summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--retroarch-config.patch27
3 files changed, 28 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b64116a465f9..2b6cef373b57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = retroarch-rbp
pkgdesc = Reference frontend for the libretro API (Raspberry Pi)
pkgver = 1.6.9
- pkgrel = 1.1
+ pkgrel = 2.1
url = http://www.libretro.com/
arch = armv7h
groups = libretro
@@ -59,7 +59,7 @@ pkgbase = retroarch-rbp
source = retroarch-1.6.9.tar.gz::https://github.com/libretro/RetroArch/archive/v1.6.9.tar.gz
source = retroarch-config.patch
sha256sums = 66dde69fde9d286e3d8f6c4a5e4b947e9030044415e75b419883b454e05d78b4
- sha256sums = f37b12754256b0bcc2f9d738f9aa1c18557fffede670a328eb0eeb2f28a32bbd
+ sha256sums = 8dca43954d05ea1f989932fb26828b6e8325394eec070c4530dd21eab3f02c44
pkgname = retroarch-rbp
diff --git a/PKGBUILD b/PKGBUILD
index b7bcd3f9d01c..d4942b20cf3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ buildarch=4
pkgname=retroarch-rbp
pkgver=1.6.9
-pkgrel=1.1
+pkgrel=2.1
pkgdesc='Reference frontend for the libretro API (Raspberry Pi)'
arch=('armv7h')
url='http://www.libretro.com/'
@@ -53,12 +53,12 @@ backup=('etc/retroarch.cfg')
source=("retroarch-${pkgver}.tar.gz::https://github.com/libretro/RetroArch/archive/v${pkgver}.tar.gz"
'retroarch-config.patch')
sha256sums=('66dde69fde9d286e3d8f6c4a5e4b947e9030044415e75b419883b454e05d78b4'
- 'f37b12754256b0bcc2f9d738f9aa1c18557fffede670a328eb0eeb2f28a32bbd')
+ '8dca43954d05ea1f989932fb26828b6e8325394eec070c4530dd21eab3f02c44')
prepare() {
cd RetroArch-${pkgver}
- patch -Np1 -i ../retroarch-config.patch
+ patch -Np0 -i ../retroarch-config.patch
}
build() {
@@ -87,9 +87,8 @@ package() {
make DESTDIR="${pkgdir}" install
- install -dm 755 "${pkgdir}"/usr/lib/retroarch/filters/{audio,video}
- install -m 644 libretro-common/audio/dsp_filters/*.so "${pkgdir}"/usr/lib/retroarch/filters/audio/
- install -m 644 gfx/video_filters/*.{filt,so} "${pkgdir}"/usr/lib/retroarch/filters/video/
+ install -Dm 644 libretro-common/audio/dsp_filters/*.{dsp,so} -t "${pkgdir}"/usr/lib/retroarch/filters/audio/
+ install -Dm 644 gfx/video_filters/*.{filt,so} -t "${pkgdir}"/usr/lib/retroarch/filters/video/
}
# vim: ts=2 sw=2 et:
diff --git a/retroarch-config.patch b/retroarch-config.patch
index 92ed0acfd179..33b4ecc0093f 100644
--- a/retroarch-config.patch
+++ b/retroarch-config.patch
@@ -1,6 +1,5 @@
-diff -rupN RetroArch-1.6.6.orig/retroarch.cfg RetroArch-1.6.6/retroarch.cfg
---- RetroArch-1.6.6.orig/retroarch.cfg 2017-08-24 15:30:11.730485158 +0200
-+++ RetroArch-1.6.6/retroarch.cfg 2017-08-24 15:32:05.506771029 +0200
+--- retroarch.cfg.orig 2017-11-21 16:40:48.000000000 +0100
++++ retroarch.cfg 2017-12-22 21:37:14.020611669 +0100
@@ -41,10 +41,10 @@
# libretro_path = "/path/to/libretro.so"
@@ -23,7 +22,7 @@ diff -rupN RetroArch-1.6.6.orig/retroarch.cfg RetroArch-1.6.6/retroarch.cfg
# Dynamic wallpapers directory. The place to store the wallpapers dynamically
# loaded by the menu depending on context.
-@@ -235,7 +235,7 @@
+@@ -235,13 +235,13 @@
# video_shader_enable = false
# Defines a directory where shaders (Cg, CGP, GLSL) are kept for easy access.
@@ -32,7 +31,23 @@ diff -rupN RetroArch-1.6.6.orig/retroarch.cfg RetroArch-1.6.6/retroarch.cfg
# CPU-based video filter. Path to a dynamic library.
# video_filter =
-@@ -411,7 +411,7 @@
+
+ # Defines a directory where CPU-based video filters are kept.
+-# video_filter_dir =
++video_filter_dir = /usr/lib/retroarch/filters/video
+
+ # Path to a font used for rendering messages. This path must be defined to enable fonts.
+ # Do note that the _full_ path of the font is necessary!
+@@ -311,7 +311,7 @@ video_message_bgcolor_opacity = 1.0
+ # audio_dsp_plugin =
+
+ # Directory where DSP plugins are kept.
+-# audio_filter_dir =
++audio_filter_dir = /usr/lib/retroarch/filters/audio
+
+ # Will sync (block) on audio. Recommended.
+ # audio_sync = true
+@@ -418,7 +418,7 @@ video_message_bgcolor_opacity = 1.0
# Input binds which are made explicit (input_playerN_*_btn/axis) will take priority over autoconfigs.
# Autoconfigs can be created with retroarch-joyconfig, manually, or with a frontend.
# Requires input_autodetect_enable to be enabled.
@@ -41,7 +56,7 @@ diff -rupN RetroArch-1.6.6.orig/retroarch.cfg RetroArch-1.6.6/retroarch.cfg
# Sets which libretro device is used for a user.
# Devices are indentified with a number.
-@@ -655,7 +655,7 @@
+@@ -662,7 +662,7 @@ video_message_bgcolor_opacity = 1.0
# menu_show_online_updater = true
# If disabled, will hide the ability to update cores (and core info files) inside the menu.