summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 124ff96f87ca..7a3544dfe931 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed Mar 14 22:42:20 UTC 2018
+# Fri Sep 7 10:50:53 UTC 2018
pkgbase = retroshare
pkgdesc = Serverless encrypted instant messenger with filesharing, chatgroups, e-mail.
pkgver = 0.6.4
@@ -9,6 +9,7 @@ pkgbase = retroshare
arch = x86_64
arch = armv6h
arch = armv7h
+ arch = aarch64
license = GPL
license = LGPL
makedepends = git
@@ -24,7 +25,9 @@ pkgbase = retroshare
provides = retroshare
conflicts = retroshare
source = https://github.com/RetroShare/RetroShare/archive/v0.6.4.tar.gz
+ source = https://github.com/RetroShare/RetroShare/commit/4d287d68bc9725f403dc7d952a927d401c5d6c97.patch
sha256sums = 84355c0f3be5ec1dfa7253e327ea1254f76f47739c233cfb8d0983ebd1a61f4a
+ sha256sums = d5b775333a351068711dc12bb50d92fde4966fcaaf393039c324b46e2f03f986
pkgname = retroshare
diff --git a/PKGBUILD b/PKGBUILD
index 572303f3fc9b..53773c8c07af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ pkgname=retroshare
pkgver=0.6.4
pkgrel=1
pkgdesc="Serverless encrypted instant messenger with filesharing, chatgroups, e-mail."
-arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="http://retroshare.sourceforge.net/"
license=('GPL' 'LGPL')
depends=('qt5-multimedia' 'qt5-x11extras' 'libupnp' 'libxss' 'libmicrohttpd' 'sqlcipher')
@@ -33,8 +33,10 @@ optdepends=('tor: tor hidden node support'
provides=("${pkgname}")
conflicts=("${pkgname}")
-source=("https://github.com/RetroShare/RetroShare/archive/v${pkgver}.tar.gz")
-sha256sums=('84355c0f3be5ec1dfa7253e327ea1254f76f47739c233cfb8d0983ebd1a61f4a')
+source=("https://github.com/RetroShare/RetroShare/archive/v${pkgver}.tar.gz"
+ "https://github.com/RetroShare/RetroShare/commit/4d287d68bc9725f403dc7d952a927d401c5d6c97.patch")
+sha256sums=('84355c0f3be5ec1dfa7253e327ea1254f76f47739c233cfb8d0983ebd1a61f4a'
+ 'd5b775333a351068711dc12bb50d92fde4966fcaaf393039c324b46e2f03f986')
# Add missing dependencies if needed
[[ "$_plugin_voip" == 'true' ]] && depends=(${depends[@]} 'ffmpeg' 'opencv')
@@ -56,6 +58,11 @@ if [[ "$_plugin_lua4rs" == 'true' ]] ; then
source=(${source[@]} 'Lua4RS::git+https://github.com/RetroShare/Lua4RS.git')
fi
+prepare() {
+ cd "${srcdir}/RetroShare-${pkgver}"
+ git apply ../4d287d68bc9725f403dc7d952a927d401c5d6c97.patch
+}
+
build() {
cd "${srcdir}/RetroShare-${pkgver}"