summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdd45b085f38..286f44851dc9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = revbayes
pkgdesc = Bayesian Phylogenetic Inference Using Graphical Models and an Interactive Model-Specification Language https://doi.org/10.1093/sysbio/syw021
- pkgver = 1.2.1
- pkgrel = 7
+ pkgver = 1.2.3
+ pkgrel = 1
url = https://github.com/revbayes/revbayes
arch = x86_64
license = GPL3
@@ -15,9 +15,9 @@ pkgbase = revbayes
depends = openlibm
conflicts = lrzsz
conflicts = revbayes-mpi
- source = git+https://github.com/revbayes/revbayes.git#tag=v1.2.1
+ source = git+https://github.com/revbayes/revbayes.git#tag=v1.2.3
source = rb.patch
- md5sums = SKIP
+ md5sums = 77b4de01b42d27b46802706a17508cdb
md5sums = f5af0159704f049f8269584883bcaa80
pkgname = revbayes
diff --git a/PKGBUILD b/PKGBUILD
index 5dece061e92a..38e177033f71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=revbayes
-pkgver=1.2.1
-pkgrel=7
+pkgver=1.2.3
+pkgrel=1
pkgdesc="Bayesian Phylogenetic Inference Using Graphical Models and an Interactive Model-Specification Language https://doi.org/10.1093/sysbio/syw021"
arch=(x86_64)
url="https://github.com/revbayes/revbayes"
@@ -10,22 +10,20 @@ makedepends=('boost' 'meson' 'ninja' 'cmake' 'git')
source=("git+$url.git#tag=v$pkgver"
"rb.patch")
conflicts=('lrzsz' 'revbayes-mpi')
-md5sums=('SKIP'
+md5sums=('77b4de01b42d27b46802706a17508cdb'
'f5af0159704f049f8269584883bcaa80')
prepare() {
cd $srcdir/$pkgname
- # fix lib issue
- patch -p1 < $srcdir/rb.patch
-
git submodule update --init --recursive
./projects/meson/generate.sh
}
build() {
cd $srcdir/$pkgname
- CXXFLAGS="${CXXFLAGS} -std=c++14" arch-meson build \
- --buildtype release
+ arch-meson build \
+ --buildtype release \
+ -Dmpi=false
ninja -C build
}