summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO37
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD75
-rw-r--r--cracklib.patch33
-rw-r--r--gnome-python.patch28
-rw-r--r--revelation.install26
6 files changed, 49 insertions, 154 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fde90573bb00..89c9936e8650 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,18 @@
-# Generated by mksrcinfo v8
-# Mon Feb 13 18:08:22 UTC 2017
pkgbase = revelation
- pkgdesc = A password manager for the GNOME desktop
- pkgver = 0.4.14
- pkgrel = 6
- url = http://revelation.olasagasti.info/
- install = revelation.install
- arch = i686
+ pkgdesc = Password manager for the GNOME desktop
+ pkgver = 0.5.5
+ pkgrel = 2
+ url = https://github.com/mikelolasagasti/revelation
arch = x86_64
license = GPL
- makedepends = intltool
- depends = gnome-python>=2.10
- depends = pycrypto>=1.9
- depends = python2-crack
- depends = desktop-file-utils
- depends = python2
- depends = hicolor-icon-theme
- depends = pkg-config
- depends = python2-dbus
- source = https://bitbucket.org/erikg/revelation/downloads/revelation-0.4.14.tar.bz2
- source = cracklib.patch
- source = gnome-python.patch
- sha256sums = 2ab3d1d8bcc2f441feb58122ee6a0fe4070412228194843a180a7b1c9e910019
- sha256sums = f5cebe215115cb5a78f470da9753be3c5ff99095f28ab57ae45d2d03b3a686d6
- sha256sums = b2803f3f0ab344453fc4f82c90c8eefe99e1b23f77de09bf598741c73458a044
+ makedepends = gobject-introspection
+ makedepends = meson
+ depends = gtk3
+ depends = libpwquality
+ depends = python-defusedxml
+ depends = python-gobject
+ depends = python-pycryptodomex
+ source = https://github.com/mikelolasagasti/revelation/releases/download/revelation-0.5.5/revelation-0.5.5.tar.xz
+ sha256sums = a20c4191595466dc90b90b0f7c4615a599974327152a4d2af87f506134ddce8f
pkgname = revelation
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 5a48c195f161..87f6ed5b82e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,41 @@
-# Maintainer: Thomas Hebb <tommyhebb@gmail.com>
+# Maintainer:
+# Contributor: MichaƂ Lisowski <lisu@riseup.net>
+# Contributor: Thomas Hebb <tommyhebb@gmail.com>
# Contributor: Jan de Groot <jgc@archlinux.org>
+
pkgname=revelation
-pkgver=0.4.14
-pkgrel=6
-pkgdesc="A password manager for the GNOME desktop"
-arch=('i686' 'x86_64')
+pkgver=0.5.5
+pkgrel=2
+pkgdesc="Password manager for the GNOME desktop"
+url="https://github.com/mikelolasagasti/revelation"
license=('GPL')
-depends=('gnome-python>=2.10' 'pycrypto>=1.9' 'python2-crack' 'desktop-file-utils' 'python2' 'hicolor-icon-theme' 'pkg-config' 'python2-dbus')
-makedepends=('intltool')
-install=revelation.install
-url="http://revelation.olasagasti.info/"
-source=("https://bitbucket.org/erikg/revelation/downloads/revelation-${pkgver}.tar.bz2"
- 'cracklib.patch'
- 'gnome-python.patch')
-sha256sums=('2ab3d1d8bcc2f441feb58122ee6a0fe4070412228194843a180a7b1c9e910019'
- 'f5cebe215115cb5a78f470da9753be3c5ff99095f28ab57ae45d2d03b3a686d6'
- 'b2803f3f0ab344453fc4f82c90c8eefe99e1b23f77de09bf598741c73458a044')
-
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- patch -uNp1 -i "${srcdir}/cracklib.patch"
- patch -uNp1 -i "${srcdir}/gnome-python.patch"
-
- ./autogen.sh
-}
+arch=('x86_64')
+
+depends=(
+ gtk3
+ libpwquality
+ python-defusedxml
+ python-gobject
+ python-pycryptodomex
+)
+makedepends=(
+ gobject-introspection
+ meson
+)
+
+_pkgsrc="$pkgname-$pkgver"
+_pkgext="tar.xz"
+source=(
+ "$url/releases/download/$_pkgsrc/$_pkgsrc.$_pkgext")
+sha256sums=(
+ 'a20c4191595466dc90b90b0f7c4615a599974327152a4d2af87f506134ddce8f'
+)
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- PYTHON=/usr/bin/python2 ./configure --prefix=/usr --sysconfdir=/etc \
- --libexecdir=/usr/lib/revelation \
- --localstatedir=/var \
- --disable-mime-update --disable-desktop-update \
- --with-python-include=/usr/include/python2.7
- make
+ arch-meson "$_pkgsrc" build
+ meson compile -C build
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 DESTDIR="${pkgdir}" install
-
- sed -i "s|#!/usr/bin/\(env \)\?python$|#!/usr/bin/\1python2|" \
- $pkgdir/usr/bin/revelation \
- $pkgdir/usr/lib/python2.7/site-packages/revelation/bundle/PBKDFv2.py
-
- install -m755 -d "${pkgdir}/usr/share/gconf/schemas"
- gconf-merge-schema "${pkgdir}/usr/share/gconf/schemas/${pkgname}.schemas" --domain revelation ${pkgdir}/etc/gconf/schemas/*.schemas || return 1
- rm -f ${pkgdir}/etc/gconf/schemas/*.schemas
+ meson install -C build --destdir "$pkgdir"
}
diff --git a/cracklib.patch b/cracklib.patch
deleted file mode 100644
index b07723515ef2..000000000000
--- a/cracklib.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -Naur revelation-0.4.14.orig/configure.ac revelation-0.4.14/configure.ac
---- revelation-0.4.14.orig/configure.ac 2012-08-14 01:08:27.190736795 -0400
-+++ revelation-0.4.14/configure.ac 2012-08-14 01:43:35.396873763 -0400
-@@ -24,7 +24,7 @@
- RVL_PYTHON_MODULE(gobject, yes)
- RVL_PYTHON_MODULE(pango, yes)
- RVL_PYTHON_MODULE(dbus, yes)
--RVL_PYTHON_MODULE(cracklib, yes)
-+RVL_PYTHON_MODULE(crack, yes)
-
-
- dnl Enable applet installation
-diff -Naur revelation-0.4.14.orig/src/lib/util.py revelation-0.4.14/src/lib/util.py
---- revelation-0.4.14.orig/src/lib/util.py 2012-08-14 01:08:27.194070085 -0400
-+++ revelation-0.4.14/src/lib/util.py 2012-08-14 01:43:53.473311172 -0400
-@@ -23,7 +23,7 @@
- # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
- #
-
--import datetime, cracklib, gettext, math, os, random, shlex, string, StringIO, traceback
-+import datetime, crack, gettext, math, os, random, shlex, string, StringIO, traceback
-
- _ = gettext.gettext
-
-@@ -94,7 +94,7 @@
- # check password with cracklib
- try:
- if len(password) < 100:
-- cracklib.FascistCheck(password)
-+ crack.FascistCheck(password)
-
- except ValueError, reason:
-
diff --git a/gnome-python.patch b/gnome-python.patch
deleted file mode 100644
index 82a02fb259bd..000000000000
--- a/gnome-python.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From dffb8b7722865a82c3a5d7ce9615b6da2313d583 Mon Sep 17 00:00:00 2001
-Message-Id: <dffb8b7722865a82c3a5d7ce9615b6da2313d583.1486417682.git.tommyhebb@gmail.com>
-From: Thomas Hebb <tommyhebb@gmail.com>
-Date: Mon, 6 Feb 2017 21:44:06 +0000
-Subject: [PATCH] Remove deprecated gnome-python dependency from configure.ac
-
-The code has not depended on the module for many years (the module was
-removed in 125cf9dc28f95617fc3b37bc29a714f708b7d2ef); however, the
-configure script was never updated to match.
----
- configure.ac | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index bdfae2a..5b6ad72 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -19,7 +19,6 @@ RVL_FDO_MIME()
- RVL_PYTHON_MODULE(Crypto, yes)
- RVL_PYTHON_MODULE(gconf, yes)
- RVL_PYTHON_MODULE(gtk, yes)
--RVL_PYTHON_MODULE(gnome, yes)
- RVL_PYTHON_MODULE(gio, yes)
- RVL_PYTHON_MODULE(gobject, yes)
- RVL_PYTHON_MODULE(pango, yes)
---
-2.11.1
-
diff --git a/revelation.install b/revelation.install
deleted file mode 100644
index 39e53e3de8bc..000000000000
--- a/revelation.install
+++ /dev/null
@@ -1,26 +0,0 @@
-pkgname=revelation
-
-post_install() {
- gconfpkg --install ${pkgname}
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- update-desktop-database -q
- update-mime-database usr/share/mime > /dev/null
-}
-
-pre_upgrade() {
- pre_remove $1
-}
-
-post_upgrade() {
- post_install $1
-}
-
-pre_remove() {
- gconfpkg --uninstall ${pkgname}
-}
-
-post_remove() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- update-desktop-database -q
- update-mime-database usr/share/mime > /dev/null
-}