summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--query-fix.patch11
3 files changed, 11 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e595a2dc52cd..db6e3855bb5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
# Generated by mksrcinfo v8
-# Fri Oct 7 09:25:08 UTC 2016
+# Fri Oct 7 13:36:26 UTC 2016
pkgbase = revoco
pkgdesc = Change the wheel behaviour of Logitech's MX-Revolution mouse.
pkgver = 0.6
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/sebastien/revoco
arch = i686
arch = x86_64
conflicts = revoco2
- source = http://downloads.sourceforge.net/project/revoco/revoco-0.6.tar.bz2
- source = query-fix.patch
- md5sums = 97da18a988893a03098bfea6f2525686
- md5sums = 0699b052b8e555e937e465f588f7300f
+ source = https://github.com/sebastien/revoco/archive/1312012b6f533fabfb8cd5b76d39508d0a909fee.zip
+ md5sums = 4a6294412e7649240b1eb222e6c73326
pkgname = revoco
diff --git a/PKGBUILD b/PKGBUILD
index 34f4b7cc3f05..cd45809a8276 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,23 @@
-# Contributor: Henrik Nymann Jensen <h@henriknj.dk>
+# Contributor: danitool<dgcbueu[at]gmail.com>, Henrik Nymann Jensen <h@henriknj.dk>
pkgname=revoco
pkgver=0.6
-pkgrel=2
+pkgrel=3
+_commit=1312012b6f533fabfb8cd5b76d39508d0a909fee
pkgdesc="Change the wheel behaviour of Logitech's MX-Revolution mouse."
arch=('i686' 'x86_64')
url="https://github.com/sebastien/revoco"
license=()
conflicts=('revoco2')
-source=(http://downloads.sourceforge.net/project/revoco/$pkgname-$pkgver.tar.bz2
-query-fix.patch)
-md5sums=('97da18a988893a03098bfea6f2525686'
- '0699b052b8e555e937e465f588f7300f')
+source=(https://github.com/sebastien/$pkgname/archive/$_commit.zip)
+md5sums=('4a6294412e7649240b1eb222e6c73326')
build() {
- cd $srcdir/$pkgname-$pkgver
- patch -p1 < ../query-fix.patch
+ cd $srcdir/$pkgname-$_commit
make || return 1
}
package() {
- cd $srcdir/$pkgname-$pkgver
+ cd $srcdir/$pkgname-$_commit
install -D -m755 revoco $pkgdir/usr/bin/revoco
}
diff --git a/query-fix.patch b/query-fix.patch
deleted file mode 100644
index eeab34b36f82..000000000000
--- a/query-fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/revoco.c 2013-08-26 14:32:57.365967373 +0200
-+++ b/revoco.c 2013-08-26 14:32:43.399300460 +0200
-@@ -280,7 +280,7 @@
- query_report(fd, 0x10, res, 6);
-
- if ((res[0] != 0x01 || res[1] != 0x81 || res[2] != 0xb1) &&
-- (res[0] != 0x02 || res[1] != 0x81 || (res[2] != 0x0d && res[2] != 0x08)))
-+ ((res[0] != 0x01 && res[0] != 0x02) || res[1] != 0x81 || (res[2] != 0x0d && res[2] != 0x08)))
- {
- printf("bad answer (%02x %02x %02x...)\n", res[0], res[1], res[2]);
- return 0;