summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD41
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d8f07209ecd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = rhythmbox-plugin-open-containing-folder
+ pkgdesc = Adds an option to open the folder containing the selected track(s) to the right click context menu of rhythmbox music player
+ pkgver = 41
+ pkgrel = 1
+ url = https://github.com/donaghhorgan/rhythmbox-plugins-open-containing-folder
+ arch = any
+ license = GPL3
+ depends = rhythmbox
+ depends = xdg-utils
+ provides = rhythmbox-plugin-open-containing-folder
+ conflicts = rhythmbox-plugin-open-containing-folder
+ source = :git+https://github.com/donaghhorgan/rhythmbox-plugins-open-containing-folder.git
+ sha256sums = SKIP
+
+pkgname = rhythmbox-plugin-open-containing-folder
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96ec5f5acd42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Aroun <login att b-vo dott fr>
+
+pkgname=rhythmbox-plugin-open-containing-folder
+_pkgname=rhythmbox-plugins-open-containing-folder
+_name=OpenContainingFolder
+pkgver=41
+pkgrel=1
+pkgdesc='Adds an option to open the folder containing the selected track(s) to the right click context menu of rhythmbox music player'
+arch=('any')
+url="https://github.com/donaghhorgan/rhythmbox-plugins-open-containing-folder"
+license=(GPL3)
+depends=(
+ rhythmbox
+ xdg-utils
+)
+makedepends=(
+ git
+)
+provides=(
+ rhythmbox-plugin-open-containing-folder
+)
+conflicts=(
+ rhythmbox-plugin-open-containing-folder
+)
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "%s" "$(git rev-list --count HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ files=( LICENSE $_name.plugin $_name.py README.md )
+ for file in "${files[@]}"
+ do
+ install -Dm644 $file "${pkgdir}/usr/lib/rhythmbox/plugins/${ name}/$file"
+ done
+}
+