summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4909bca5a96c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = rickyd
+ pkgdesc = An easily moddable clone of Rick Dangerous
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = http://sourceforge.net/projects/rickyd/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = sdl2_image
+ depends = sdl2_mixer
+ depends = sdl2_ttf
+ source = http://downloads.sourceforge.net/sourceforge/rickyd/rickyd-src-0.2.0.tar.gz
+ md5sums = 3775f51ad19c81602d8c211c838ee69a
+
+pkgname = rickyd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..773c8a3006fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: megadriver <megadriver at gmx dot com>
+
+pkgname=rickyd
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="An easily moddable clone of Rick Dangerous"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/rickyd/"
+license=("GPL3")
+depends=('sdl2_image' 'sdl2_mixer' 'sdl2_ttf')
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-src-$pkgver.tar.gz)
+md5sums=('3775f51ad19c81602d8c211c838ee69a')
+
+build() {
+ cd $srcdir/$pkgname-src-$pkgver
+ ./bootstrap.sh
+ make distclean
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-src-$pkgver
+ make DESTDIR=$pkgdir install
+}