summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD69
-rw-r--r--RoR.desktop9
-rw-r--r--RoRConfig.desktop9
-rw-r--r--plugins.cfg11
-rw-r--r--rigsofrods.pngbin0 -> 2635 bytes
6 files changed, 134 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40c616418cc6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = rigsofrods-git
+ pkgdesc = An open source vehicle simulator based on soft-body physics
+ pkgver = LATEST
+ pkgrel = 3
+ url = http://rigsofrods.com
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ makedepends = cmake
+ makedepends = git
+ depends = angelscript-2.22.1
+ depends = openal
+ depends = wxgtk
+ depends = ogre-1.8
+ depends = caelum-ogre1.8
+ depends = mygui-ogre1.8
+ depends = ogre-1.8-pagedgeometry
+ depends = socketw
+ provides = rigsofrods
+ conflicts = rigsofrods
+ conflicts = rigsofrods-hg
+ replaces = rigsofrods-hg
+ source = git+https://github.com/RigsOfRods/rigs-of-rods.git
+ source = plugins.cfg
+ source = rigsofrods.png
+ source = RoRConfig.desktop
+ source = RoR.desktop
+ sha512sums = SKIP
+ sha512sums = 1fffff3e1e1bcf55fb2604c3874457571151082c09e5bcbccf452d6d60b01f2fff825fab601bf428196310c97d67ea1b9346f6de6b17a9906024f867aaa2ceb4
+ sha512sums = 8280ddec6dba37e66c323e469c1894bacc3b592b6ea1f7fd3876bc9e7253b14b4949c3c51d7dd47ad7bd78e085fbe51aad83b1e8d0b0755deda426129e4a6710
+ sha512sums = 40a000061d72245265d53d7c2ce0c4acc81eb3dddb6f6beda4b693a154e34922b8eb5c8400062b58c5f43a74be6cdaab938c1cd6427aebfc691d1fa52517fe2d
+ sha512sums = b0c04df93fa622d27ba485df1253ee786ebe42acb2c7b2f5d9657f22623503ee995845905f782c7b550625a4db0dbfdd924e4757b2daf21f84bb9cb3f6d683af
+
+pkgname = rigsofrods-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5235eaede63d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+# Maintainer: Artem Vorotnikov <artem@vorotnikov.me>
+# Contributor: tritonas00 <tritonas00@gmail.com>
+
+pkgname=rigsofrods-git
+pkgver=LATEST
+_pkgname=rigsofrods
+_gitname=rigs_of_rods
+pkgrel=3
+pkgdesc="An open source vehicle simulator based on soft-body physics"
+arch=('i686' 'x86_64')
+url="http://rigsofrods.com"
+license=('GPL')
+depends=('angelscript-2.22.1' 'openal' 'wxgtk' 'ogre-1.8' 'caelum-ogre1.8' 'mygui-ogre1.8' 'ogre-1.8-pagedgeometry' 'socketw')
+makedepends=('boost' 'cmake' 'git')
+replaces=('rigsofrods-hg')
+conflicts=('rigsofrods' 'rigsofrods-hg')
+provides=('rigsofrods')
+source=("git+https://github.com/RigsOfRods/rigs-of-rods.git"
+ "plugins.cfg"
+ "rigsofrods.png"
+ "RoRConfig.desktop"
+ "RoR.desktop")
+sha512sums=('SKIP'
+ '1fffff3e1e1bcf55fb2604c3874457571151082c09e5bcbccf452d6d60b01f2fff825fab601bf428196310c97d67ea1b9346f6de6b17a9906024f867aaa2ceb4'
+ '8280ddec6dba37e66c323e469c1894bacc3b592b6ea1f7fd3876bc9e7253b14b4949c3c51d7dd47ad7bd78e085fbe51aad83b1e8d0b0755deda426129e4a6710'
+ '40a000061d72245265d53d7c2ce0c4acc81eb3dddb6f6beda4b693a154e34922b8eb5c8400062b58c5f43a74be6cdaab938c1cd6427aebfc691d1fa52517fe2d'
+ 'b0c04df93fa622d27ba485df1253ee786ebe42acb2c7b2f5d9657f22623503ee995845905f782c7b550625a4db0dbfdd924e4757b2daf21f84bb9cb3f6d683af'
+)
+
+build() {
+ cd "$srcdir/${_gitname}"
+
+ export PKG_CONFIG_PATH="/opt/OGRE-1.8/lib/pkgconfig:/opt/MyGUI-OGRE1.8/lib/pkgconfig:/opt/Caelum-OGRE1.8/lib/pkgconfig:/opt/PagedGeometry-OGRE1.8/lib/pkgconfig:$PKG_CONFIG_PATH"
+ export LD_LIBRARY_PATH="/opt/OGRE-1.8/lib:/opt/MyGUI-OGRE1.8/lib:/opt/Caelum-OGRE1.8/lib:/opt/PagedGeometry-OGRE1.8/lib:$LD_LIBRARY_PATH"
+
+ # patch for MyGUI >3.20, see https://github.com/RigsOfRods/rigs-of-rods/issues/156
+ sed -i 's/key.toValue/key.getValue/' ./source/main/gui/GUIInputManager.cpp ./source/main/gui/Console.cpp ./source/main/gui/LobbyGUI.cpp
+
+ # get a clean build dir
+ [[ -d build ]] && rm -rf build && find ./bin -type f -maxdepth 1 ! -name resources -delete
+ mkdir build && cd build
+
+ cmake .. \
+ -DROR_USE_MYGUI="TRUE" \
+ -DROR_USE_OPENAL="TRUE" \
+ -DROR_USE_SOCKETW="TRUE" \
+ -DROR_USE_PAGED="TRUE" \
+ -DROR_USE_CAELUM="TRUE" \
+ -DROR_USE_ANGELSCRIPT="TRUE" \
+ -DMYGUI_INCLUDE_DIRS=/opt/MyGUI-OGRE1.8/include/MYGUI \
+ -DMYGUI_OGRE_PLATFORM=/opt/MyGUI-OGRE1.8/lib/libMyGUI.OgrePlatform.a \
+ -DCAELUM_INCLUDE_DIRS=/opt/Caelum-OGRE1.8/include \
+ -DCAELUM_LIBRARIES=/opt/Caelum-OGRE1.8/lib/libCaelum.so \
+ -DPAGED_INCLUDE_DIRS=/opt/PagedGeometry-OGRE1.8/include \
+ -DPAGED_LIBRARIES=/opt/PagedGeometry-OGRE1.8/lib/libPagedGeometry.a \
+ -DCMAKE_BUILD_TYPE=RELEASE
+
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/opt/${_pkgname}"
+ cp -r $srcdir/${_gitname}/bin/* "$pkgdir/opt/${_pkgname}/"
+
+ install -Dm755 rigsofrods.png "$pkgdir/usr/share/pixmaps/rigsofrods.png"
+ install -Dm755 RoR.desktop "$pkgdir/usr/share/applications/RoR.desktop"
+ install -Dm755 RoRConfig.desktop "$pkgdir/usr/share/applications/RoRConfig.desktop"
+ install -Dm755 plugins.cfg "$pkgdir/opt/${_pkgname}/plugins.cfg"
+}
diff --git a/RoR.desktop b/RoR.desktop
new file mode 100644
index 000000000000..684747173d4d
--- /dev/null
+++ b/RoR.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Encoding=UTF-8
+Name=Rigs of Rods
+Comment=An open source vehicle simulator based on soft-body physics
+Icon=rigsofrods.png
+Exec=/opt/rigsofrods/RoR
+Terminal=false
+Categories=Application;Game;
diff --git a/RoRConfig.desktop b/RoRConfig.desktop
new file mode 100644
index 000000000000..afccdb42c6ab
--- /dev/null
+++ b/RoRConfig.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Encoding=UTF-8
+Name=Rigs of Rods (config)
+Comment=Configuration utility for Rigs of Rods
+Icon=rigsofrods.png
+Exec=/opt/rigsofrods/RoRConfig
+Terminal=false
+Categories=Application;Game;
diff --git a/plugins.cfg b/plugins.cfg
new file mode 100644
index 000000000000..d195d1308d24
--- /dev/null
+++ b/plugins.cfg
@@ -0,0 +1,11 @@
+# Defines plugins to load
+
+# Define plugin folder
+PluginFolder=/opt/OGRE-1.8/lib/OGRE
+
+# Define plugins
+Plugin=RenderSystem_GL
+Plugin=Plugin_ParticleFX
+Plugin=Plugin_OctreeSceneManager
+Plugin=Plugin_CgProgramManager
+Plugin=../../../../opt/Caelum-OGRE1.8/lib/libCaelum.so
diff --git a/rigsofrods.png b/rigsofrods.png
new file mode 100644
index 000000000000..80ab89219997
--- /dev/null
+++ b/rigsofrods.png
Binary files differ