summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a3b1b1189bb..4294b7674b7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = riscv64-unknown-elf-gcc
pkgdesc = The GNU Compiler Collection - cross compiler for 32bit and 64bit RISC-V bare-metal
- pkgver = 12.1.0
+ pkgver = 13.2.0
pkgrel = 2
url = http://gcc.gnu.org/
arch = i686
@@ -13,9 +13,9 @@ pkgbase = riscv64-unknown-elf-gcc
depends = libmpc
options = !emptydirs
options = !strip
- source = https://gcc.gnu.org/pub/gcc/releases/gcc-12.1.0/gcc-12.1.0.tar.xz
- source = https://libisl.sourceforge.io/isl-0.24.tar.xz
- sha256sums = 62fd634889f31c02b64af2c468f064b47ad1ca78411c45abe6ac4b5f8dd19c7b
- sha256sums = 043105cc544f416b48736fff8caf077fb0663a717d06b1113f16e391ac99ebad
+ source = https://gcc.gnu.org/pub/gcc/releases/gcc-13.2.0/gcc-13.2.0.tar.xz
+ source = https://libisl.sourceforge.io/isl-0.26.tar.xz
+ sha256sums = e275e76442a6067341a27f04c5c6b83d8613144004c0413528863dc6b5c743da
+ sha256sums = a0b5cb06d24f9fa9e77b55fabbe9a3c94a336190345c2555f9915bb38e976504
pkgname = riscv64-unknown-elf-gcc
diff --git a/PKGBUILD b/PKGBUILD
index 930fd0a9a7a0..1c65a0590fb5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_target=riscv64-unknown-elf
pkgname=$_target-gcc
-pkgver=12.1.0
-_islver=0.24
+pkgver=13.2.0
+_islver=0.26
pkgrel=2
#_snapshot=7-20170504
pkgdesc='The GNU Compiler Collection - cross compiler for 32bit and 64bit RISC-V bare-metal'
@@ -15,8 +15,8 @@ depends=("$_target-binutils" 'zlib' 'libmpc')
options=(!emptydirs !strip)
source=("https://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-$pkgver.tar.xz"
"https://libisl.sourceforge.io/isl-$_islver.tar.xz")
-sha256sums=('62fd634889f31c02b64af2c468f064b47ad1ca78411c45abe6ac4b5f8dd19c7b'
- '043105cc544f416b48736fff8caf077fb0663a717d06b1113f16e391ac99ebad')
+sha256sums=('e275e76442a6067341a27f04c5c6b83d8613144004c0413528863dc6b5c743da'
+ 'a0b5cb06d24f9fa9e77b55fabbe9a3c94a336190345c2555f9915bb38e976504')
if [[ -n "$_snapshot" ]]; then
_basedir=gcc-$_snapshot