summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
-rw-r--r--newlib.patch12
3 files changed, 14 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16dc41ee6d86..680ed27475d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = riscv64-unknown-elf-gcc
pkgdesc = The GNU Compiler Collection - cross compiler for 32bit and 64bit RISC-V bare-metal
- pkgver = 7.3.0
+ pkgver = 8.2.0
pkgrel = 1
url = http://gcc.gnu.org/
arch = i686
@@ -13,14 +13,12 @@ pkgbase = riscv64-unknown-elf-gcc
depends = libmpc
options = !emptydirs
options = !strip
- source = https://gcc.gnu.org/pub/gcc/releases/gcc-7.3.0/gcc-7.3.0.tar.xz
- source = http://isl.gforge.inria.fr/isl-0.18.tar.bz2
- source = https://sourceware.org/pub/newlib/newlib-3.0.0.tar.gz
- source = newlib.patch
- sha256sums = 832ca6ae04636adbb430e865a1451adf6979ab44ca1c8374f61fba65645ce15c
- sha256sums = 6b8b0fd7f81d0a957beb3679c81bbb34ccc7568d5682844d8924424a0dadcb1b
- sha256sums = c8566335ee74e5fcaeb8595b4ebd0400c4b043d6acb3263ecb1314f8f5501332
- sha256sums = 13533973c4604d7d51f056432b6d967b116214999d81899f93e6e1472d754e44
+ source = https://gcc.gnu.org/pub/gcc/releases/gcc-8.2.0/gcc-8.2.0.tar.xz
+ source = http://isl.gforge.inria.fr/isl-0.19.tar.bz2
+ source = https://sourceware.org/pub/newlib/newlib-3.0.0.20180831.tar.gz
+ sha256sums = 196c3c04ba2613f893283977e6011b2345d1cd1af9abeac58e916b1aab3e0080
+ sha256sums = d59726f34f7852a081fbd3defd1ab2136f174110fc2e0c8d10bb122173fa9ed8
+ sha256sums = 3ad3664f227357df15ff34e954bfd9f501009a647667cd307bf0658aefd6eb5b
pkgname = riscv64-unknown-elf-gcc
diff --git a/PKGBUILD b/PKGBUILD
index 72f286889647..26081a4c4f60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
_target=riscv64-unknown-elf
pkgname=$_target-gcc
-pkgver=7.3.0
-_islver=0.18
-_newlibver=3.0.0
+pkgver=8.2.0
+_islver=0.19
+_newlibver=3.0.0.20180831
pkgrel=1
#_snapshot=7-20170504
pkgdesc='The GNU Compiler Collection - cross compiler for 32bit and 64bit RISC-V bare-metal'
@@ -15,12 +15,10 @@ depends=("$_target-binutils" 'zlib' 'libmpc')
options=(!emptydirs !strip)
source=("https://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-$pkgver.tar.xz"
"http://isl.gforge.inria.fr/isl-$_islver.tar.bz2"
- "https://sourceware.org/pub/newlib/newlib-$_newlibver.tar.gz"
- 'newlib.patch')
-sha256sums=('832ca6ae04636adbb430e865a1451adf6979ab44ca1c8374f61fba65645ce15c'
- '6b8b0fd7f81d0a957beb3679c81bbb34ccc7568d5682844d8924424a0dadcb1b'
- 'c8566335ee74e5fcaeb8595b4ebd0400c4b043d6acb3263ecb1314f8f5501332'
- '13533973c4604d7d51f056432b6d967b116214999d81899f93e6e1472d754e44')
+ "https://sourceware.org/pub/newlib/newlib-$_newlibver.tar.gz")
+sha256sums=('196c3c04ba2613f893283977e6011b2345d1cd1af9abeac58e916b1aab3e0080'
+ 'd59726f34f7852a081fbd3defd1ab2136f174110fc2e0c8d10bb122173fa9ed8'
+ '3ad3664f227357df15ff34e954bfd9f501009a647667cd307bf0658aefd6eb5b')
if [[ -n "$_snapshot" ]]; then
_basedir=gcc-$_snapshot
@@ -29,10 +27,6 @@ else
fi
prepare() {
- cd newlib-$_newlibver
- patch -Np1 -i "$srcdir/newlib.patch"
- cd ..
-
cd $_basedir
# link isl for in-tree builds
diff --git a/newlib.patch b/newlib.patch
deleted file mode 100644
index e4aad7b21dc6..000000000000
--- a/newlib.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur newlib-3.0.0.orig/newlib/libc/stdlib/exit.c newlib-3.0.0/newlib/libc/stdlib/exit.c
---- newlib-3.0.0.orig/newlib/libc/stdlib/exit.c 2018-01-18 19:07:45.000000000 +0100
-+++ newlib-3.0.0/newlib/libc/stdlib/exit.c 2018-02-15 12:51:39.396775246 +0100
-@@ -54,7 +54,7 @@
- {
- #ifdef _LITE_EXIT
- /* Refer to comments in __atexit.c for more details of lite exit. */
-- void __call_exitprocs (int, void *)) __attribute__((weak);
-+ void __call_exitprocs (int, void *) __attribute__((weak));
- if (__call_exitprocs)
- #endif
- __call_exitprocs (code, NULL);