summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92fa44b038bb..86e2e4b49249 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = rke-bin
pkgdesc = Rancher Kubernetes Engine, an extremely simple, lightning fast Kubernetes installer that works everywhere.
- pkgver = v0.1.17
+ pkgver = v0.2.0
pkgrel = 1
url = https://github.com/rancher/rke
arch = x86_64
license = Apache
provides = rke
- source = https://github.com/rancher/rke/releases/download/v0.1.17/rke_linux-amd64
- md5sums = 926a0b72b9595de53ea000bcef710064
+ source = rke-v0.2.0::https://github.com/rancher/rke/releases/download/v0.2.0/rke_linux-amd64
+ md5sums = 7fa7070ebc5db1d3090146675578103f
pkgname = rke-bin
diff --git a/PKGBUILD b/PKGBUILD
index b4bed5ea19a2..0f986b0ea254 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Victor <victor@xirion.net>
pkgname=rke-bin
-pkgver=v0.1.17
+pkgver=v0.2.0
pkgrel=1
pkgdesc='Rancher Kubernetes Engine, an extremely simple, lightning fast Kubernetes installer that works everywhere. '
arch=('x86_64')
url='https://github.com/rancher/rke'
license=('Apache')
provides=('rke')
-source=("https://github.com/rancher/rke/releases/download/${pkgver}/rke_linux-amd64")
-md5sums=('926a0b72b9595de53ea000bcef710064')
+_rke_file=rke-$pkgver
+source=($_rke_file::"https://github.com/rancher/rke/releases/download/${pkgver}/rke_linux-amd64")
+md5sums=('7fa7070ebc5db1d3090146675578103f')
package() {
- mkdir -p "${pkgdir}/usr/bin"
- install -D -m755 rke_linux-amd64 "${pkgdir}/usr/bin/rke"
+ install -Dm 755 "$srcdir/$_rke_file" "${pkgdir}/usr/bin/rke"
}