summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rw-r--r--detect_guichan.patch13
3 files changed, 0 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c26ce6e5084f..3c48f5655ad4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,10 +20,8 @@ pkgbase = rlvm-git
provides = rlvm
conflicts = rlvm
source = git+https://github.com/eglaysher/rlvm.git
- source = detect_guichan.patch
source = freetype.patch
md5sums = SKIP
- md5sums = 2e2602bca4bc2dd576834f406f5c3af5
md5sums = 60d11c6a9b259eda3ee69c6a6ddaffac
pkgname = rlvm-git
diff --git a/PKGBUILD b/PKGBUILD
index 2a78f416cf3d..e41492d30b47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,10 +11,8 @@ makedepends=(git scons boost)
provides=(rlvm)
conflicts=(rlvm)
source=('git+https://github.com/eglaysher/rlvm.git'
- 'detect_guichan.patch'
'freetype.patch')
md5sums=('SKIP'
- '2e2602bca4bc2dd576834f406f5c3af5'
'60d11c6a9b259eda3ee69c6a6ddaffac')
pkgver() {
@@ -25,7 +23,6 @@ pkgver() {
prepare() {
cd "$srcdir/rlvm/"
rm -r "$srcdir/rlvm/vendor/guichan"
- patch -p1 < "$srcdir/detect_guichan.patch"
patch -p1 < "$srcdir/freetype.patch"
}
diff --git a/detect_guichan.patch b/detect_guichan.patch
deleted file mode 100644
index faf4ac34c7f9..000000000000
--- a/detect_guichan.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/SConstruct
-+++ b/SConstruct
-@@ -279,8 +279,8 @@
- CheckForSystemLibrary(config, library_dict, subcomponents)
-
- if not config.CheckGuichan():
-- print ("(Using included copy of guichan)")
-- subcomponents.append("guichan")
-+ print ("(Somehow guichan is not detected, include anyway.)")
-+ env.Append(LIBS = ['guichan', 'guichan_opengl', 'guichan_sdl'])
-
- # Get the configuration from sdl and freetype
- env.ParseConfig("sdl-config --cflags")