summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD37
-rw-r--r--detect_guichan.patch14
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f47a1d3b712c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = rlvm
+ pkgdesc = RealLive clone for Linux and OSX. Git version.
+ pkgver = 20150819
+ pkgrel = 1
+ url = http://www.elliotglaysher.org/rlvm/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = scons
+ makedepends = boost
+ depends = boost-libs>=1.46
+ depends = glew
+ depends = libmad
+ depends = sdl_mixer
+ depends = sdl_image
+ depends = sdl_ttf
+ depends = guichan
+ source = git+https://github.com/eglaysher/rlvm.git
+ source = detect_guichan.patch
+ md5sums = SKIP
+ md5sums = 357e8680838cf8b27ab3c3eaa73d3107
+
+pkgname = rlvm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63d3869d6835
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: maz-1 <ohmygod19993 at gmail dot com>
+pkgname=rlvm
+pkgver=20150819
+pkgrel=1
+pkgdesc="RealLive clone for Linux and OSX. Git version."
+arch=(i686 x86_64)
+url="http://www.elliotglaysher.org/rlvm/"
+license=('GPL')
+depends=('boost-libs>=1.46' glew libmad sdl_mixer sdl_image sdl_ttf guichan)
+makedepends=(scons boost)
+source=('git+https://github.com/eglaysher/rlvm.git' 'detect_guichan.patch')
+md5sums=('SKIP' '357e8680838cf8b27ab3c3eaa73d3107')
+
+pkgver() {
+ cd "$srcdir/rlvm/"
+ git log -1 --format="%cd" --date=short | sed 's|-||g'
+}
+
+build() {
+ cd "$srcdir/rlvm/"
+ patch -p1 < "$srcdir/detect_guichan.patch"
+
+ scons --release
+
+}
+
+package() {
+ cd "$srcdir/rlvm/"
+
+ install -D "$srcdir/rlvm/build/release/rlvm" "$pkgdir/usr/bin/rlvm"
+ install -D "$srcdir/rlvm/src/platforms/gtk/rlvm.desktop" "$pkgdir/usr/share/applications/rlvm.desktop"
+ for r in 16 24 32 48 128 256; do
+ install -d "$pkgdir/usr/share/icons/hicolor/${r}x$r"
+ install -D "$srcdir/rlvm/resources/$r/rlvm.png" "$pkgdir/usr/share/icons/hicolor/${r}x$r/apps/rlvm.png"
+ done
+}
+
diff --git a/detect_guichan.patch b/detect_guichan.patch
new file mode 100644
index 000000000000..d57eedd97805
--- /dev/null
+++ b/detect_guichan.patch
@@ -0,0 +1,14 @@
+diff -Naur a/SConstruct b/SConstruct
+--- a/SConstruct 2015-10-14 00:57:12.750504352 +0000
++++ b/SConstruct 2015-10-14 00:51:18.000000000 +0000
+@@ -180,7 +180,9 @@
+ }
+ """, ".cc")[0]
+ if not ret:
+- context.env.Replace(LIBS = lastLIBS)
++ # context.env.Replace(LIBS = lastLIBS)
++ #fix for archlinux
++ context.Message('(For some reason guichan is not detected, include anyway.)')
+ context.Result( ret )
+ return ret
+