summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 23 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8365c818bdeb..2ac224d3e9d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = rmfuse
pkgdesc = FUSE access to the reMarkable Cloud
- pkgver = 0.1.1
+ pkgver = 0.2.0
pkgrel = 1
url = https://github.com/rschroll/rmfuse/
arch = any
license = MIT
makedepends = python-setuptools
- depends = python-pyfuse3
depends = python-bidict
depends = python-rmcl
depends = python-rmrl
- source = https://files.pythonhosted.org/packages/source/r/rmfuse/rmfuse-0.1.1.tar.gz
- sha256sums = 358454373e505a56b8645b7f15d42f0ec118ccf28d3e3e8f4530210ddb67cf22
+ optdepends = python-pyfuse3: for FUSE3 (recommended)
+ optdepends = python-llfuse: for FUSE2
+ source = https://files.pythonhosted.org/packages/source/r/rmfuse/rmfuse-0.2.0.tar.gz
+ source = xdg.py::https://raw.githubusercontent.com/srstevenson/xdg/5.0.1/src/xdg/__init__.py
+ sha256sums = 0a9bcbe1e24f0bacedeb947007e7363d6d082bb72e26bea042d6c7ccddb12d91
+ sha256sums = 93a5ba17785c5e00d24ebd0e148d36470076c03fa16cf7e9a113a7d8fb1bceba
pkgname = rmfuse
diff --git a/PKGBUILD b/PKGBUILD
index d0ad39874237..162385af1b3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,36 @@
# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+# Maintainer: f3fora <f3 dot foradori at gmail dot com>
pkgname=rmfuse
-pkgver=0.1.1
+pkgver=0.2.0
pkgrel=1
pkgdesc="FUSE access to the reMarkable Cloud"
arch=(any)
url="https://github.com/rschroll/rmfuse/"
license=('MIT')
-depends=('python-pyfuse3' 'python-bidict' 'python-rmcl' 'python-rmrl')
+depends=('python-bidict' 'python-rmcl' 'python-rmrl')
+optdepends=('python-pyfuse3: for FUSE3 (recommended)'
+ 'python-llfuse: for FUSE2')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/r/rmfuse/rmfuse-$pkgver.tar.gz")
-sha256sums=('358454373e505a56b8645b7f15d42f0ec118ccf28d3e3e8f4530210ddb67cf22')
+source=("https://files.pythonhosted.org/packages/source/r/rmfuse/rmfuse-$pkgver.tar.gz"
+ "xdg.py::https://raw.githubusercontent.com/srstevenson/xdg/5.0.1/src/xdg/__init__.py")
+sha256sums=('0a9bcbe1e24f0bacedeb947007e7363d6d082bb72e26bea042d6c7ccddb12d91'
+ '93a5ba17785c5e00d24ebd0e148d36470076c03fa16cf7e9a113a7d8fb1bceba')
build() {
cd "$srcdir"/rmfuse-$pkgver
+ sed -r 's/^from xdg /from .xdg /' -i rmfuse/*.py
python setup.py build
}
package() {
+ _site_packages=$(python -sSc 'import site; print(site.getsitepackages()[0])')
+
cd "$srcdir"/rmfuse-$pkgver
python setup.py install -O1 --skip-build --root="$pkgdir"
install -Dm0644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ # vendoring xdg.py due to conflicts with python-pyxdg
+ install -Dm0644 "$srcdir"/xdg.py "$pkgdir$_site_packages"/rmfuse/xdg.py
+ rm "$pkgdir$_site_packages"/rmfuse-$pkgver-*.egg-info/requires.txt
}