summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 21 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6635cf06548..c20912819487 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Sep 13 23:20:23 UTC 2016
+# Sat Oct 22 10:07:29 UTC 2016
pkgbase = roccat-tools
pkgdesc = Userland applications to configure and make extended use of ROCCAT devices
- pkgver = 5.4.0
+ pkgver = 5.5.0
pkgrel = 1
url = http://roccat.sourceforge.net
arch = i686
@@ -19,8 +19,8 @@ pkgbase = roccat-tools
depends = libgudev
depends = lua>=5.3
optdepends = kmod-roccat: Adds support for the old kone device.
- source = http://downloads.sourceforge.net/project/roccat/roccat-tools/roccat-tools-5.4.0.tar.bz2
- md5sums = e00124437d29af7f16f4b5b02ff01b35
+ source = http://downloads.sourceforge.net/project/roccat/roccat-tools/roccat-tools-5.5.0.tar.bz2
+ md5sums = 1cd328de42261c736ee275b33c8ecbb8
pkgname = roccat-tools-common
pkgdesc = ROCCAT tools common files
@@ -109,6 +109,10 @@ pkgname = roccat-tools-savu
pkgdesc = Userland applications to configure and make extended use of ROCCAT Savu devices
depends = roccat-tools-common
+pkgname = roccat-tools-sova
+ pkgdesc = Userland applications to configure and make extended use of ROCCAT Sova devices
+ depends = roccat-tools-common
+
pkgname = roccat-tools-suora
pkgdesc = Userland applications to configure and make extended use of ROCCAT Suora devices
depends = roccat-tools-common
diff --git a/PKGBUILD b/PKGBUILD
index 7e8cd5edc474..1d8c53c6188a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,11 +25,12 @@ pkgname=('roccat-tools-common'
'roccat-tools-ryosmkfx'
'roccat-tools-ryostkl'
'roccat-tools-savu'
+ 'roccat-tools-sova'
'roccat-tools-suora'
'roccat-tools-tyon'
'roccat-tools-nyth')
pkgbase=roccat-tools
-pkgver=5.4.0
+pkgver=5.5.0
pkgrel=1
pkgdesc='Userland applications to configure and make extended use of ROCCAT devices'
arch=('i686' 'x86_64')
@@ -39,7 +40,7 @@ depends=('libgaminggear>=0.15.0' 'libcanberra' 'gtk2' 'libnotify>=0.7.0' 'dbus-g
makedepends=('cmake')
optdepends=('kmod-roccat: Adds support for the old kone device.')
source=("http://downloads.sourceforge.net/project/roccat/roccat-tools/roccat-tools-$pkgver.tar.bz2")
-md5sums=('e00124437d29af7f16f4b5b02ff01b35')
+md5sums=('1cd328de42261c736ee275b33c8ecbb8')
build() {
cd "$srcdir/$pkgbase-$pkgver"
@@ -273,6 +274,16 @@ package_roccat-tools-suora() {
install -Dm644 udev/90-roccat-suora.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-suora.rules
}
+package_roccat-tools-sova() {
+ pkgdesc='Userland applications to configure and make extended use of ROCCAT Sova devices'
+ depends=('roccat-tools-common')
+
+ cd "$srcdir/$pkgbase-$pkgver/sova"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$pkgbase-$pkgver"
+ install -Dm644 udev/90-roccat-sova.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-sova.rules
+}
+
package_roccat-tools-nyth() {
pkgdesc='Userland applications to configure and make extended use of ROCCAT Nyth devices'
depends=('roccat-tools-common')