summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 19 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f46f9f37894..b0cf485b01b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = roccat-tools
pkgdesc = Userland applications to configure and make extended use of ROCCAT devices
pkgver = 3.1.0
- pkgrel = 1
+ pkgrel = 2
url = http://roccat.sourceforge.net
arch = i686
arch = x86_64
@@ -81,7 +81,11 @@ pkgname = roccat-tools-pyra
depends = roccat-tools-common
pkgname = roccat-tools-ryosmk
- pkgdesc = Userland applications to configure and make extended use of ROCCAT Ryos devices
+ pkgdesc = Userland applications to configure and make extended use of ROCCAT RyosMK devices
+ depends = roccat-tools-common
+
+pkgname = roccat-tools-ryostkl
+ pkgdesc = Userland applications to configure and make extended use of ROCCAT RyosTKL devices
depends = roccat-tools-common
pkgname = roccat-tools-savu
diff --git a/PKGBUILD b/PKGBUILD
index 8e0b3d88a1ba..7fb22a72f14f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,11 +18,12 @@ pkgname=('roccat-tools-common'
'roccat-tools-lua'
'roccat-tools-pyra'
'roccat-tools-ryosmk'
+ 'roccat-tools-ryostkl'
'roccat-tools-savu'
'roccat-tools-tyon')
pkgbase=roccat-tools
pkgver=3.1.0
-pkgrel=1
+pkgrel=2
pkgdesc='Userland applications to configure and make extended use of ROCCAT devices'
arch=('i686' 'x86_64')
url='http://roccat.sourceforge.net'
@@ -182,7 +183,7 @@ package_roccat-tools-pyra() {
}
package_roccat-tools-ryosmk() {
- pkgdesc='Userland applications to configure and make extended use of ROCCAT Ryos devices'
+ pkgdesc='Userland applications to configure and make extended use of ROCCAT RyosMK devices'
depends=('roccat-tools-common')
cd "$srcdir/$pkgbase-$pkgver/ryosmk"
@@ -191,6 +192,16 @@ package_roccat-tools-ryosmk() {
install -Dm644 udev/90-roccat-ryosmk.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-ryosmk.rules
}
+package_roccat-tools-ryostkl() {
+ pkgdesc='Userland applications to configure and make extended use of ROCCAT RyosTKL devices'
+ depends=('roccat-tools-common')
+
+ cd "$srcdir/$pkgbase-$pkgver/ryostkl"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$pkgbase-$pkgver"
+ install -Dm644 udev/90-roccat-ryostkl.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-ryostkl.rules
+}
+
package_roccat-tools-savu() {
pkgdesc='Userland applications to configure and make extended use of ROCCAT Savu devices'
depends=('roccat-tools-common')