summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 36 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b12ecf97f571..b94f221c5739 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = roccat-tools
pkgdesc = Userland applications to configure and make extended use of ROCCAT devices
pkgver = 2.0.0
- pkgrel = 1
+ pkgrel = 2
url = http://roccat.sourceforge.net
arch = i686
arch = x86_64
@@ -11,7 +11,6 @@ pkgbase = roccat-tools
depends = libcanberra
depends = gtk2
depends = libnotify>=0.7.0
- depends = libusb
depends = dbus-glib
depends = udev
depends = hicolor-icon-theme
@@ -49,6 +48,11 @@ pkgname = roccat-tools-konepure
depends = roccat-tools-common
depends = roccat-tools-konextd
+pkgname = roccat-tools-konepuremilitary
+ pkgdesc = Userland applications to configure and make extended use of ROCCAT Kone Pure Military devices
+ depends = roccat-tools-common
+ depends = roccat-tools-konepure
+
pkgname = roccat-tools-konepureoptical
pkgdesc = Userland applications to configure and make extended use of ROCCAT Kone Pure optical devices
depends = roccat-tools-common
@@ -59,6 +63,11 @@ pkgname = roccat-tools-konextd
depends = roccat-tools-common
depends = roccat-tools-koneplus
+pkgname = roccat-tools-konextdoptical
+ pkgdesc = Userland applications to configure and make extended use of ROCCAT Kone XTD Optical devices
+ depends = roccat-tools-common
+ depends = roccat-tools-konepuremilitary
+
pkgname = roccat-tools-kovaplus
pkgdesc = Userland applications to configure and make extended use of ROCCAT Kova[+] devices
depends = roccat-tools-common
diff --git a/PKGBUILD b/PKGBUILD
index c5acbb46856f..f36a28cf605f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,10 @@ pkgname=('roccat-tools-common'
'roccat-tools-kone'
'roccat-tools-koneplus'
'roccat-tools-konepure'
+ 'roccat-tools-konepuremilitary'
'roccat-tools-konepureoptical'
'roccat-tools-konextd'
+ 'roccat-tools-konextdoptical'
'roccat-tools-kovaplus'
'roccat-tools-lua'
'roccat-tools-pyra'
@@ -19,12 +21,12 @@ pkgname=('roccat-tools-common'
'roccat-tools-savu')
pkgbase=roccat-tools
pkgver=2.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='Userland applications to configure and make extended use of ROCCAT devices'
arch=('i686' 'x86_64')
url='http://roccat.sourceforge.net'
license=('GPL2')
-depends=('libgaminggear=0.3.0' 'libcanberra' 'gtk2' 'libnotify>=0.7.0' 'libusb' 'dbus-glib' 'udev' 'hicolor-icon-theme')
+depends=('libgaminggear=0.3.0' 'libcanberra' 'gtk2' 'libnotify>=0.7.0' 'dbus-glib' 'udev' 'hicolor-icon-theme')
makedepends=('cmake')
optdepends=('kmod-roccat: Adds support for some devices not yet in vanilla kernel')
conflicts=
@@ -38,10 +40,6 @@ build() {
make
}
-package_roccat-tools() {
- /bin/true
-}
-
package_roccat-tools-common() {
pkgdesc='ROCCAT tools common files'
install=roccat-tools.install
@@ -122,6 +120,16 @@ package_roccat-tools-konepureoptical() {
install -Dm644 udev/90-roccat-konepureoptical.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-konepureoptical.rules
}
+package_roccat-tools-konepuremilitary() {
+ pkgdesc='Userland applications to configure and make extended use of ROCCAT Kone Pure Military devices'
+ depends=('roccat-tools-common' 'roccat-tools-konepure')
+
+ cd "$srcdir/$pkgbase-$pkgver/konepuremilitary"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$pkgbase-$pkgver"
+ install -Dm644 udev/90-roccat-savu.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-konepuremilitary.rules
+}
+
package_roccat-tools-konextd() {
pkgdesc='Userland applications to configure and make extended use of ROCCAT Kone XTD devices'
depends=('roccat-tools-common' 'roccat-tools-koneplus')
@@ -132,6 +140,16 @@ package_roccat-tools-konextd() {
install -Dm644 udev/90-roccat-konextd.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-konextd.rules
}
+package_roccat-tools-konextdoptical() {
+ pkgdesc='Userland applications to configure and make extended use of ROCCAT Kone XTD Optical devices'
+ depends=('roccat-tools-common' 'roccat-tools-konepuremilitary')
+
+ cd "$srcdir/$pkgbase-$pkgver/konextdoptical"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$pkgbase-$pkgver"
+ install -Dm644 udev/90-roccat-savu.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-konextdoptical.rules
+}
+
package_roccat-tools-kovaplus() {
pkgdesc='Userland applications to configure and make extended use of ROCCAT Kova[+] devices'
depends=('roccat-tools-common')
@@ -180,4 +198,4 @@ package_roccat-tools-savu() {
make DESTDIR="$pkgdir/" install
cd "$srcdir/$pkgbase-$pkgver"
install -Dm644 udev/90-roccat-savu.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-savu.rules
-}
+} \ No newline at end of file