summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d44220d09ad8..7387b296a91f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = roccat-tools
pkgdesc = Userland applications to configure and make extended use of ROCCAT devices
pkgver = 3.4.0
- pkgrel = 1
+ pkgrel = 2
url = http://roccat.sourceforge.net
arch = i686
arch = x86_64
@@ -89,6 +89,7 @@ pkgname = roccat-tools-ryosmk
pkgname = roccat-tools-ryostkl
pkgdesc = Userland applications to configure and make extended use of ROCCAT RyosTKL devices
depends = roccat-tools-common
+ depends = roccat-tools-ryosmk
pkgname = roccat-tools-savu
pkgdesc = Userland applications to configure and make extended use of ROCCAT Savu devices
diff --git a/PKGBUILD b/PKGBUILD
index 6b34ea7b22e6..c9a40b8267c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,6 +2,7 @@
# Contributor: Nuno Araujo <nuno.araujo@russo79.com>
# Contributor: Xpander <xpander0@gmail.com>
# Contributor: Stefan Achatz <erazor_de@users.soruceforge.net>
+# Contributor: Zachary Lund <admin@computerquip.com>
pkgname=('roccat-tools-common'
'roccat-tools-arvo'
@@ -23,7 +24,7 @@ pkgname=('roccat-tools-common'
'roccat-tools-tyon')
pkgbase=roccat-tools
pkgver=3.4.0
-pkgrel=1
+pkgrel=2
pkgdesc='Userland applications to configure and make extended use of ROCCAT devices'
arch=('i686' 'x86_64')
url='http://roccat.sourceforge.net'
@@ -45,7 +46,11 @@ build() {
# https://sourceforge.net/p/roccat/bugs/51/
patch -p1 -i ../udev-compilation-error-fix.patch
- cmake . -DCMAKE_INSTALL_PREFIX=/usr -DUDEVDIR=/usr/lib/udev/rules.d -DWITHOUT_PYTHON=TRUE
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUDEVDIR=/usr/lib/udev/rules.d \
+ -DWITHOUT_PYTHON=TRUE \
+ -DLIBDIR="/usr/lib"
make
}
@@ -201,7 +206,7 @@ package_roccat-tools-ryosmk() {
package_roccat-tools-ryostkl() {
pkgdesc='Userland applications to configure and make extended use of ROCCAT RyosTKL devices'
- depends=('roccat-tools-common')
+ depends=('roccat-tools-common' 'roccat-tools-ryosmk')
cd "$srcdir/$pkgbase-$pkgver/ryostkl"
make DESTDIR="$pkgdir/" install