summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
-rw-r--r--udev-compilation-error-fix.patch11
3 files changed, 2 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad7932124d0b..fa7251f290bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,9 +17,7 @@ pkgbase = roccat-tools
depends = libgudev
optdepends = kmod-roccat: Adds support for the old kone device.
source = http://downloads.sourceforge.net/project/roccat/roccat-tools/roccat-tools-3.6.1.tar.bz2
- source = udev-compilation-error-fix.patch
md5sums = a37dfbe7ea06519924aede890047cf6c
- md5sums = 414d6306796c659a3adc86ef213e3569
pkgname = roccat-tools-common
pkgdesc = ROCCAT tools common files
diff --git a/PKGBUILD b/PKGBUILD
index 3bad55484e77..f149662a814f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,19 +35,13 @@ depends=('libgaminggear=0.11.1' 'libcanberra' 'gtk2' 'libnotify>=0.7.0' 'dbus-gl
makedepends=('cmake')
optdepends=('kmod-roccat: Adds support for the old kone device.')
conflicts=
-source=("http://downloads.sourceforge.net/project/roccat/roccat-tools/roccat-tools-$pkgver.tar.bz2"
- 'udev-compilation-error-fix.patch')
+source=("http://downloads.sourceforge.net/project/roccat/roccat-tools/roccat-tools-$pkgver.tar.bz2")
-md5sums=('a37dfbe7ea06519924aede890047cf6c'
- '414d6306796c659a3adc86ef213e3569')
+md5sums=('a37dfbe7ea06519924aede890047cf6c')
build() {
cd "$srcdir/$pkgbase-$pkgver"
- # See here for more detail and progress on this:
- # https://sourceforge.net/p/roccat/bugs/51/
- patch -p1 -i ../udev-compilation-error-fix.patch
-
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DUDEVDIR=/usr/lib/udev/rules.d \
diff --git a/udev-compilation-error-fix.patch b/udev-compilation-error-fix.patch
deleted file mode 100644
index 25583848d20f..000000000000
--- a/udev-compilation-error-fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --git a/kone/libkoneeventhandler/CMakeLists.txt b/kone/libkoneeventhandler/CMakeLists.txt
-index d460bba..f633e92 100644
---- a/kone/libkoneeventhandler/CMakeLists.txt
-+++ b/kone/libkoneeventhandler/CMakeLists.txt
-@@ -21,6 +21,7 @@ TARGET_LINK_LIBRARIES(libkoneeventhandler
- libroccathelper
- ${GAMINGGEAR0_LIBRARY}
- ${DBUS-GLIB_LIBRARIES}
-+ ${GUDEV_LIBRARIES}
- ${GLIB2_LIBRARIES}
- )