summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD45
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..632e6c913c16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = rofi-code-git
+ pkgdesc = Use rofi to quickly open Visual Studio Code or Codium workspaces.
+ pkgver = 0.2.r1.gf804543
+ pkgrel = 1
+ url = https://www.github.com/Coffelius/rofi-code
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = go
+ provides = rofi-code
+ source = rofi-code-git::git+https://www.github.com/Coffelius/rofi-code
+ md5sums = SKIP
+
+pkgname = rofi-code-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d788e48d734
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Gabriel Ortega <coffelius@gmail.com>
+pkgname=rofi-code-git
+pkgrel=1
+epoch=
+pkgver=0.2.r1.gf804543
+pkgdesc="Use rofi to quickly open Visual Studio Code or Codium workspaces."
+arch=($CARCH)
+url="https://www.github.com/Coffelius/rofi-code"
+license=('MIT')
+groups=()
+depends=()
+makedepends=(
+ 'git'
+ 'go'
+ )
+checkdepends=()
+optdepends=()
+provides=(rofi-code)
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("${pkgname}::git+$url")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ make dist
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -DT rofi-code "${pkgdir}/usr/bin/rofi-code"
+ install -DT LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -DT README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}