summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5b3cedfbd6d7..51f593f8dfb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,13 +19,16 @@ conflicts=("rofi-greenclip-beta")
replaces=("rofi-greenclip-beta")
backup=()
options=('!strip')
-install=
source=("https://github.com/erebe/greenclip/releases/download/3.0/greenclip")
noextract=()
sha256sums=("a56cbba8e60e972e9db20757554db344de912ff9e7cd72e76d542796b9fa43ed")
package() {
- kill -9 "$(pidof greenclip)" || test 1
+ pid_greenclip="$(pidof greenclip)"
+ if [ -n "$pid_greenclip" ]; then
+ kill -9 "$(pidof greenclip)" || test 1
+ fi
+
rm -rf ~/.config/greenclip.cfg ~/.cache/greenclip.*
install -Dm 755 greenclip "$pkgdir/usr/bin/greenclip"
}