summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD52
-rw-r--r--rofimoji-git.install6
3 files changed, 43 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a052211e385e..a498b8538a29 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = rofimoji-git
- pkgdesc = Character picker for rofi
- pkgver = 6.0.0.r0.gc5c9f05
+ pkgdesc = Emoji, unicode and general character picker for rofi and rofi-likes
+ pkgver = 6.2.0.r15.g473196a
pkgrel = 1
url = https://github.com/fdw/rofimoji
- install = rofimoji-git.install
arch = any
license = MIT
makedepends = git
@@ -13,11 +12,18 @@ pkgbase = rofimoji-git
depends = python-configargparse
optdepends = emoji-font: for the emojis character file
optdepends = nerd-fonts: for the nerd_font character file
- optdepends = rofi: for the X.Org selector
+ optdepends = otf-font-awesome: for the fontawesome6 character file
+ optdepends = ttf-font-awesome: for the fontawesome6 character file
+ optdepends = bemenu: for a generic selector
+ optdepends = dmenu: for one of the X.Org selectors
+ optdepends = rofi: for one of the X.Org selectors
optdepends = xclip: for one of the X.Org clipboarders
optdepends = xsel: for one of the X.Org clipboarders
optdepends = xdotool: for the X.Org typer
- optdepends = wofi: for the Wayland selector
+ optdepends = fuzzel: for one of the Wayland selectors
+ optdepends = tofi: for one of the Wayland selectors
+ optdepends = wmenu: for one of the Wayland selectors
+ optdepends = wofi: for one of the Wayland selectors
optdepends = wl-clipboard: for the Wayland clipboarder
optdepends = wtype: for the Wayland typer
provides = rofimoji
diff --git a/PKGBUILD b/PKGBUILD
index d1c22ab58a3d..793885a82411 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,66 @@
# Maintainer: Daniel M. Capella <polyzen@archlinux.org>
pkgname=rofimoji-git
-pkgver=6.0.0.r0.gc5c9f05
+_name=${pkgname%-git}
+pkgver=6.2.0.r15.g473196a
pkgrel=1
-pkgdesc='Character picker for rofi'
+pkgdesc='Emoji, unicode and general character picker for rofi and rofi-likes'
arch=('any')
url=https://github.com/fdw/rofimoji
license=('MIT')
depends=('python-configargparse')
makedepends=('git' 'python-build' 'python-installer' 'python-poetry-core')
-optdepends=('emoji-font: for the emojis character file'
- 'nerd-fonts: for the nerd_font character file'
- 'rofi: for the X.Org selector'
- 'xclip: for one of the X.Org clipboarders'
- 'xsel: for one of the X.Org clipboarders'
- 'xdotool: for the X.Org typer'
- 'wofi: for the Wayland selector'
- 'wl-clipboard: for the Wayland clipboarder'
- 'wtype: for the Wayland typer')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-install=$pkgname.install
+optdepends=(
+ 'emoji-font: for the emojis character file'
+ 'nerd-fonts: for the nerd_font character file'
+ 'otf-font-awesome: for the fontawesome6 character file'
+ 'ttf-font-awesome: for the fontawesome6 character file'
+
+ 'bemenu: for a generic selector'
+
+ 'dmenu: for one of the X.Org selectors'
+ 'rofi: for one of the X.Org selectors'
+ 'xclip: for one of the X.Org clipboarders'
+ 'xsel: for one of the X.Org clipboarders'
+ 'xdotool: for the X.Org typer'
+
+ 'fuzzel: for one of the Wayland selectors'
+ 'tofi: for one of the Wayland selectors'
+ 'wmenu: for one of the Wayland selectors'
+ 'wofi: for one of the Wayland selectors'
+ 'wl-clipboard: for the Wayland clipboarder'
+ 'wtype: for the Wayland typer'
+)
+provides=("$_name")
+conflicts=("$_name")
source=("git+$url.git")
b2sums=('SKIP')
pkgver() {
- cd ${pkgname%-git}
+ cd "$_name"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd ${pkgname%-git}
+ cd "$_name"
# Remove include list https://github.com/pypa/wheel/issues/92
sed -i '/^include =/,/]/d' pyproject.toml
}
build() {
- cd ${pkgname%-git}
+ cd "$_name"
python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
- cd ${pkgname%-git}
+ cd "$_name"
python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 -t "$pkgdir"/usr/share/man/man1 \
- src/picker/docs/${pkgname%-git}.1
+ src/picker/docs/"$_name".1
# Symlink license file
local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
install -d "$pkgdir"/usr/share/licenses/$pkgname
- ln -s "$site_packages"/${pkgname%-git}-${pkgver%%.r*}.dist-info/LICENSE \
+ ln -s "$site_packages"/"$_name"-${pkgver%%.r*}.dist-info/LICENSE \
"$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
diff --git a/rofimoji-git.install b/rofimoji-git.install
deleted file mode 100644
index cf87c7ea3cc4..000000000000
--- a/rofimoji-git.install
+++ /dev/null
@@ -1,6 +0,0 @@
-post_install() {
- cat << EOF
-rofimoji requires an appropriate "selector", "clipboarder", and "typer" to be
-installed for your display server.
-EOF
-}