summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--LICENSE24
-rw-r--r--PKGBUILD44
-rw-r--r--romvault.desktop11
-rw-r--r--romvault.pngbin0 -> 7540 bytes
5 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..077abe7d9f02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = romvault
+ pkgdesc = RomVault is a tool for managing your ROMs and DATs for emulators, like libretro
+ pkgver = 2.2.1
+ pkgrel = 1
+ url = http://www.romvault.com/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = mono
+ source = http://www.romvault.com//download/ROMVault_V2.2.1.zip
+ source = https://raw.githubusercontent.com/gjefferyes/RomVault/master/LICENSE
+ source = romvault.desktop
+ source = romvault.png
+ sha256sums = e02ed613d2101cccf40747b228df651a6e99988d81e0d12ba2a0056edaf36691
+ sha256sums = 996bf0d32dc11506ea2635d64474c24399fab25933463f27d70cfa1d50431a16
+ sha256sums = 36a042ca80b6eb4d025dc6b6d9a75f68dfdf8f5dd4db04423447cf9bd999c202
+ sha256sums = d368d14e844f2dd6f5b2d04b31d9a70f0af6f3ec72669f5b6d98b161a8bec1d6
+
+pkgname = romvault
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..74b0fecd733a
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,24 @@
+ Released under the respect the work of the original author license.
+ -------------------------------------------------------------------
+
+The source code for RomVault has been released for the benefit of the emulation community.
+This means you should ask yourself if you make a change/improvement/branch of this code, does your changes
+also benefit the emulation community? If so then please give back to the community in a respectful way.
+
+What does giving back to the community in a respectful way mean:
+ Ideally it means contribute your changes back to the author of the source, so that your changes can be worked into the main build.
+ If you make a reasonably large change that you think others will benefit from put out your own branches for other people to try,
+ and then maybe this can also be worked into the main code.
+
+ It means DO NOT make a small change/fix, re-brand the program and claim you are the greatest developer ever for releasing 'your' software.
+ This type of behaviour is disrespectful to the original author and the emulation community, and is against the nature of this license.
+
+If you want to use large parts of this code (such as the DAT reader or torrentZip library) in your own project go right ahead,
+I hope you can do something cool with this code to add to or improve your new and existing projects. Please let the author know how you
+are using it, it would be cool to hear about other things this is being used for.
+
+DO NOT sell this software or any derivative works from this software without permission from the author.
+I have put 100's of hours of development into this code and only ever asked for donations to support this project.
+So if you go and grab this code and start selling it or derivative works, that is disrespecting the nature of this license,
+and so not permitted without permission.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f7198200ba7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Oliver Jaksch <arch-aur@com-in.de>
+
+pkgname=romvault
+pkgver=2.2.1
+pkgrel=1
+pkgdesc="RomVault is a tool for managing your ROMs and DATs for emulators, like libretro"
+arch=('i686' 'x86_64')
+url="http://www.romvault.com/"
+license=('custom')
+depends=('mono')
+
+source=(${url}/download/ROMVault_V${pkgver}.zip
+ "https://raw.githubusercontent.com/gjefferyes/RomVault/master/LICENSE"
+ 'romvault.desktop'
+ 'romvault.png')
+
+sha256sums=('e02ed613d2101cccf40747b228df651a6e99988d81e0d12ba2a0056edaf36691'
+ '996bf0d32dc11506ea2635d64474c24399fab25933463f27d70cfa1d50431a16'
+ '36a042ca80b6eb4d025dc6b6d9a75f68dfdf8f5dd4db04423447cf9bd999c202'
+ 'd368d14e844f2dd6f5b2d04b31d9a70f0af6f3ec72669f5b6d98b161a8bec1d6')
+
+package() {
+ mkdir -p -m775 "${pkgdir}/opt/${pkgname}"
+ cd "${pkgdir}/opt/${pkgname}"
+ bsdtar -xf "${srcdir}/ROMVault_V${pkgver}.zip"
+
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/opt/${pkgname}/LICENSE"
+ install -D -m 644 ${srcdir}/romvault.desktop ${pkgdir}/usr/share/applications/romvault.desktop
+ install -D -m 644 ${srcdir}/romvault.png ${pkgdir}/usr/share/pixmaps/romvault.png
+ # chmod 644 *.exe
+ # chmod -R 775 "DATRoot" "ROMRoot" "ToSort"
+ # chown -R root:games "${pkgdir}/opt/${pkgname}"
+
+ msg2 "Please create some subdirectorys ie. somewhere in your HOME and set"
+ msg2 "these as your working area in programs settings."
+ msg2 "---"
+ msg2 "A documentation and some subsets of DAT files can be found at"
+ msg2 "<https://github.com/mist-devel/mist-board/tree/master/rom_manager>"
+ msg2 "and a video that shows a quick HowTo can be found at"
+ msg2 "<http://www.youtube.com/embed/yUOIYYbZuAg>"
+ msg2 "---"
+ msg2 "You'll find more information about RomVault on it's home at <${url}> and"
+ msg2 "at MiST's home at <https://github.com/mist-devel/mist-board/wiki/RomManagement>"
+}
diff --git a/romvault.desktop b/romvault.desktop
new file mode 100644
index 000000000000..384c32ff4418
--- /dev/null
+++ b/romvault.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=ROMVault
+GenericName=RomVault
+Comment=RomVault is a multi-dat management software, managing you ROMs and DATs for emulator machines
+Exec=mono /opt/romvault/ROMVault22.exe
+Icon=/usr/share/pixmaps/romvault.png
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Application;Game
diff --git a/romvault.png b/romvault.png
new file mode 100644
index 000000000000..42d916c0db47
--- /dev/null
+++ b/romvault.png
Binary files differ