summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD28
-rw-r--r--disable-gcc-abi-check.diff4
-rw-r--r--python3.diff8
-rw-r--r--root.install25
-rw-r--r--rootd2
-rw-r--r--settings.cmake7
7 files changed, 37 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b64cd13fa44..6739eacadfa9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,33 +1,31 @@
pkgbase = root
pkgdesc = C++ data analysis framework and interpreter from CERN.
pkgver = 6.06.06
- pkgrel = 2
+ pkgrel = 3
url = http://root.cern.ch
- install = root.install
arch = i686
arch = x86_64
license = LGPL2.1
makedepends = cmake
depends = cfitsio
- depends = desktop-file-utils
depends = fftw
depends = ftgl
- depends = gcc-fortran
depends = glew
depends = graphviz
depends = gsl
- depends = gtk-update-icon-cache
+ depends = hicolor-icon-theme
depends = intel-tbb
depends = libafterimage
depends = libiodbc
depends = libmysqlclient
depends = postgresql-libs
depends = python
- depends = shared-mime-info
depends = sqlite
depends = tex-gyre-fonts
depends = unixodbc
depends = xmlrpc-c
+ optdepends = gcc-fortran: Enable the Fortran components of ROOT
+ optdepends = tcsh: Legacy CSH support
options = !emptydirs
source = https://root.cern.ch/download/root_v6.06.06.source.tar.gz
source = call_PyErr_Clear_if_no_such_attribute.patch
@@ -39,20 +37,20 @@ pkgbase = root
source = settings.cmake
md5sums = 4308449892210c8d36e36924261fea26
md5sums = f36f7bff97ed7232d8534c2ef166b2bf
- md5sums = 89d3caaa1d73a623c56a42f21dfdd669
- md5sums = e1f1eb398dec2a66bb790ef277b3ab91
+ md5sums = 5a4a67f59d553cf86d5b09fdfb204352
+ md5sums = 464eae7414433aa684cf9017204267cb
md5sums = 0e883ad44f99da9bc7c23bc102800b62
md5sums = e2cf69b204192b5889ceb5b4dedc66f7
- md5sums = efd06bfa230cc2194b38e0c8939e72af
- md5sums = 0dad3217a5d6a2106e14024e839008eb
+ md5sums = f973e17f573f0f313395d34d2e82eeb6
+ md5sums = 168175a1685c408ffd02020520b1074e
sha256sums = 0a7d702a130a260c72cb6ea754359eaee49a8c4531b31f23de0bfcafe3ce466b
sha256sums = 437ed0fb2c46d5ca8e37cc689f87dfe12429f6a243d4e5cf2d395a177de7e90f
- sha256sums = d9fea8991d42a78cd694f9798615274e96a185cbbd6608b4b80c76d5e43982a6
- sha256sums = 51dbcf86d9973e7b7204fc20ff0c3c3aacea01ee126e14e2fb3c9f33825cc558
+ sha256sums = e03fff4accf7cee4e7329b305f1e0df7bf804dbced08d52566af789bc77ea0b0
+ sha256sums = d566bc44f0df1915ac81c41b8ef7eff0d9fec8728533b00b9e654a2a4eff9af1
sha256sums = 71ed39f7e5a605a6a02e3d0ba79c997b8e7f02551898c27112eb78f07d9d8244
sha256sums = b103d46705883590d9e07aafb890ec1150f63dc2ca5f40d67e6ebef49a6d0a32
- sha256sums = 6a4ef7b32710d414ee47d16310b77b95e4cf1d3550209cf8a41d38a945d05e5f
- sha256sums = 066bed78a24003cdb06c97af34356e29ffb20626f76975267e7e17f36a125be4
+ sha256sums = 3c45b03761d5254142710b7004af0077f18efece7c95511910140d0542c8de8a
+ sha256sums = 077c7651f51c56ba02c0aa61bb4aa99fdc11c30e5e565072b652eb028f387814
pkgname = root
diff --git a/PKGBUILD b/PKGBUILD
index ae25e9a86fcd..cb0b4188004c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,34 +6,33 @@
pkgname=root
pkgver=6.06.06
-pkgrel=2
+pkgrel=3
pkgdesc='C++ data analysis framework and interpreter from CERN.'
arch=('i686' 'x86_64')
url='http://root.cern.ch'
license=('LGPL2.1')
makedepends=('cmake')
depends=('cfitsio'
-'desktop-file-utils'
'fftw'
'ftgl'
-'gcc-fortran'
'glew'
'graphviz'
'gsl'
-'gtk-update-icon-cache'
+'hicolor-icon-theme'
'intel-tbb'
'libafterimage'
'libiodbc'
'libmysqlclient'
'postgresql-libs'
'python'
-'shared-mime-info'
'sqlite'
'tex-gyre-fonts' # solve the pixelized font problem as per Arch Wiki
'unixodbc'
'xmlrpc-c'
)
-install='root.install'
+optdepends=('gcc-fortran: Enable the Fortran components of ROOT'
+ 'tcsh: Legacy CSH support'
+)
options=('!emptydirs')
source=("https://root.cern.ch/download/root_v${pkgver}.source.tar.gz"
'call_PyErr_Clear_if_no_such_attribute.patch'
@@ -45,20 +44,20 @@ source=("https://root.cern.ch/download/root_v${pkgver}.source.tar.gz"
'settings.cmake')
md5sums=('4308449892210c8d36e36924261fea26'
'f36f7bff97ed7232d8534c2ef166b2bf'
- '89d3caaa1d73a623c56a42f21dfdd669'
- 'e1f1eb398dec2a66bb790ef277b3ab91'
+ '5a4a67f59d553cf86d5b09fdfb204352'
+ '464eae7414433aa684cf9017204267cb'
'0e883ad44f99da9bc7c23bc102800b62'
'e2cf69b204192b5889ceb5b4dedc66f7'
- 'efd06bfa230cc2194b38e0c8939e72af'
- '0dad3217a5d6a2106e14024e839008eb')
+ 'f973e17f573f0f313395d34d2e82eeb6'
+ '168175a1685c408ffd02020520b1074e')
sha256sums=('0a7d702a130a260c72cb6ea754359eaee49a8c4531b31f23de0bfcafe3ce466b'
'437ed0fb2c46d5ca8e37cc689f87dfe12429f6a243d4e5cf2d395a177de7e90f'
- 'd9fea8991d42a78cd694f9798615274e96a185cbbd6608b4b80c76d5e43982a6'
- '51dbcf86d9973e7b7204fc20ff0c3c3aacea01ee126e14e2fb3c9f33825cc558'
+ 'e03fff4accf7cee4e7329b305f1e0df7bf804dbced08d52566af789bc77ea0b0'
+ 'd566bc44f0df1915ac81c41b8ef7eff0d9fec8728533b00b9e654a2a4eff9af1'
'71ed39f7e5a605a6a02e3d0ba79c997b8e7f02551898c27112eb78f07d9d8244'
'b103d46705883590d9e07aafb890ec1150f63dc2ca5f40d67e6ebef49a6d0a32'
- '6a4ef7b32710d414ee47d16310b77b95e4cf1d3550209cf8a41d38a945d05e5f'
- '066bed78a24003cdb06c97af34356e29ffb20626f76975267e7e17f36a125be4')
+ '3c45b03761d5254142710b7004af0077f18efece7c95511910140d0542c8de8a'
+ '077c7651f51c56ba02c0aa61bb4aa99fdc11c30e5e565072b652eb028f387814')
prepare(){
## https://sft.its.cern.ch/jira/browse/ROOT-6924
cd ${pkgname}-${pkgver}
@@ -108,4 +107,3 @@ package() {
rm -rf ${pkgdir}/etc/root/daemons
}
-
diff --git a/disable-gcc-abi-check.diff b/disable-gcc-abi-check.diff
index 3d0300d4f1a8..b01782a7501a 100644
--- a/disable-gcc-abi-check.diff
+++ b/disable-gcc-abi-check.diff
@@ -1,6 +1,6 @@
diff -rupN {old,root-*}/cmake/modules/CheckCompiler.cmake
---- old/cmake/modules/CheckCompiler.cmake 2016-07-06 18:36:49.000000000 +0200
-+++ root-6.06.06/cmake/modules/CheckCompiler.cmake 2016-08-05 14:28:00.218968142 +0200
+--- old/cmake/modules/CheckCompiler.cmake 2016-07-06 18:36:49.000000000 +0200
++++ root-6.06.06/cmake/modules/CheckCompiler.cmake 2016-08-05 14:28:00.218968142 +0200
@@ -51,15 +51,6 @@ if (CMAKE_COMPILER_IS_GNUCXX)
endif()
message(STATUS "Found GCC. Major version ${GCC_MAJOR}, minor version ${GCC_MINOR}")
diff --git a/python3.diff b/python3.diff
index 34ad10dfab17..dff3f8fbdacf 100644
--- a/python3.diff
+++ b/python3.diff
@@ -1,6 +1,6 @@
diff -rupN old/tmva/pymva/inc/TMVA/PyMethodBase.h root-6.06.06/tmva/pymva/inc/TMVA/PyMethodBase.h
---- old/tmva/pymva/inc/TMVA/PyMethodBase.h 2016-07-06 18:36:49.000000000 +0200
-+++ root-6.06.06/tmva/pymva/inc/TMVA/PyMethodBase.h 2016-08-05 13:56:31.839179271 +0200
+--- old/tmva/pymva/inc/TMVA/PyMethodBase.h 2016-07-06 18:36:49.000000000 +0200
++++ root-6.06.06/tmva/pymva/inc/TMVA/PyMethodBase.h 2016-08-05 13:56:31.839179271 +0200
@@ -81,7 +81,7 @@ namespace TMVA {
// default destructur
virtual ~PyMethodBase();
@@ -11,8 +11,8 @@ diff -rupN old/tmva/pymva/inc/TMVA/PyMethodBase.h root-6.06.06/tmva/pymva/inc/TM
static void PyFinalize();
static void PySetProgramName(TString name);
diff -rupN old/tmva/pymva/src/PyMethodBase.cxx root-6.06.06/tmva/pymva/src/PyMethodBase.cxx
---- old/tmva/pymva/src/PyMethodBase.cxx 2016-07-06 18:36:49.000000000 +0200
-+++ root-6.06.06/tmva/pymva/src/PyMethodBase.cxx 2016-08-05 14:07:21.225701275 +0200
+--- old/tmva/pymva/src/PyMethodBase.cxx 2016-07-06 18:36:49.000000000 +0200
++++ root-6.06.06/tmva/pymva/src/PyMethodBase.cxx 2016-08-05 14:07:21.225701275 +0200
@@ -82,7 +82,7 @@ PyObject *PyMethodBase::Eval(TString cod
}
diff --git a/root.install b/root.install
deleted file mode 100644
index afabb7aea55d..000000000000
--- a/root.install
+++ /dev/null
@@ -1,25 +0,0 @@
-post_install() {
- update-desktop-database >/dev/null
-
- update-mime-database /usr/share/mime >/dev/null
-
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-}
-
-post_upgrade() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-}
-
-pre_remove() {
- # leave for pre 5.30.03-3
- if [[ $(vercmp $1 5.30.03-3) == -1 ]]; then
- cat etc/ld.so.conf | grep -v '/usr/lib/root' >/tmp/.pacroot
- mv /tmp/.pacroot etc/ld.so.conf
- chmod 644 etc/ld.so.conf
- sbin/ldconfig -r .
- fi
-}
-
-post_remove() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-}
diff --git a/rootd b/rootd
index fb2c3388ca24..3767e57f09f8 100644
--- a/rootd
+++ b/rootd
@@ -32,6 +32,6 @@ case "$1" in
$0 start
;;
*)
- echo "usage: $0 {start|stop|restart}"
+ echo "usage: $0 {start|stop|restart}"
esac
exit 0
diff --git a/settings.cmake b/settings.cmake
index 6c288ac68f07..9b268aaa3726 100644
--- a/settings.cmake
+++ b/settings.cmake
@@ -1,11 +1,14 @@
set (CMAKE_BUILD_TYPE Release CACHE STRING "" FORCE)
set (CMAKE_C_FLAGS "-pthread -pipe -fstack-protector-strong -O2 -march=native -mtune=native" CACHE STRING "" FORCE)
-set (CMAKE_CXX_FLAGS "-D_GLIBCXX_USE_CXX11_ABI=0 -pthread -pipe -fstack-protector-strong -O2 -march=native" CACHE STRING "" FORCE)
-set (CMAKE_SHARED_LINKER_FLAGS "-pthread -Wl,--no-undefined" CACHE STRING "" FORCE)
+set (CMAKE_CXX_FLAGS "-D_GLIBCXX_USE_CXX11_ABI=0 -pthread -pipe -fstack-protector-strong -O2 -march=native -mtune=native" CACHE STRING "" FORCE)
+set (CMAKE_EXE_LINKER_FLAGS "-pthread -Wl,-O1,--sort-common,--as-needed,-z,relro -Wl,--no-undefined" CACHE STRING "" FORCE)
+set (CMAKE_MODULE_LINKER_FLAGS "-pthread -Wl,-O1,--sort-common,--as-needed,-z,relro -Wl,--no-undefined" CACHE STRING "" FORCE)
+set (CMAKE_SHARED_LINKER_FLAGS "-pthread -Wl,-O1,--sort-common,--as-needed,-z,relro -Wl,--no-undefined" CACHE STRING "" FORCE)
set (BUILD_SHARED_LIBS OFF CACHE BOOL "" FORCE) # this option is currently incompatible
set (CMAKE_INSTALL_PREFIX /usr CACHE PATH "" FORCE)
set (CMAKE_INSTALL_SYSCONFDIR /etc CACHE PATH "" FORCE)
set (CMAKE_INSTALL_DATAROOTDIR /usr/share CACHE PATH "" FORCE)
+set (LLVM_ENABLE_CXX1Y ON CACHE BOOL "" FORCE)
set (LLVM_ENABLE_THREADS ON CACHE BOOL "" FORCE) # try to workaround pthread issue
set (asimage ON CACHE BOOL "" FORCE)
set (builtin_afterimage OFF CACHE BOOL "" FORCE)