summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
-rw-r--r--call_PyErr_Clear_if_no_such_attribute.patch16
3 files changed, 28 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 956761d052cb..e2c81b065e0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Apr 20 07:47:30 UTC 2016
+# Tue May 10 16:02:31 UTC 2016
pkgbase = root
pkgdesc = C++ data analysis framework and interpreter from CERN.
- pkgver = 6.06.02
+ pkgver = 6.06.04
pkgrel = 1
url = http://root.cern.ch
install = root.install
@@ -29,18 +29,18 @@ pkgbase = root
depends = gtk-update-icon-cache
depends = libafterimage
options = !emptydirs
- source = https://root.cern.ch/download/root_v6.06.02.source.tar.gz
+ source = https://root.cern.ch/download/root_v6.06.04.source.tar.gz
source = root.sh
source = rootd
source = root.xml
source = python3.diff
- source = param.diff
- md5sums = e9b8b86838f65b0a78d8d02c66c2ec55
+ source = call_PyErr_Clear_if_no_such_attribute.patch
+ md5sums = 55a2f98dd4cea79c9c4e32407c2d6d17
md5sums = 0e883ad44f99da9bc7c23bc102800b62
md5sums = efd06bfa230cc2194b38e0c8939e72af
md5sums = e2cf69b204192b5889ceb5b4dedc66f7
md5sums = 1777520d65cc545b5416ee2fed0cd45c
- md5sums = b76fed6aae7b48c8ec0b756670ccde91
+ md5sums = f36f7bff97ed7232d8534c2ef166b2bf
pkgname = root
diff --git a/PKGBUILD b/PKGBUILD
index 349872e18600..33e92cb47ea2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Sebastian Voecking <voeck@web.de>
pkgname=root
-pkgver=6.06.02
+pkgver=6.06.04
pkgrel=1
pkgdesc='C++ data analysis framework and interpreter from CERN.'
arch=('i686' 'x86_64')
@@ -36,26 +36,23 @@ source=("https://root.cern.ch/download/root_v${pkgver}.source.tar.gz"
'rootd'
'root.xml'
'python3.diff'
-'param.diff')
-md5sums=('e9b8b86838f65b0a78d8d02c66c2ec55'
+'call_PyErr_Clear_if_no_such_attribute.patch')
+md5sums=('55a2f98dd4cea79c9c4e32407c2d6d17'
'0e883ad44f99da9bc7c23bc102800b62'
'efd06bfa230cc2194b38e0c8939e72af'
'e2cf69b204192b5889ceb5b4dedc66f7'
'1777520d65cc545b5416ee2fed0cd45c'
- 'b76fed6aae7b48c8ec0b756670ccde91')
+ 'f36f7bff97ed7232d8534c2ef166b2bf')
prepare(){
## https://sft.its.cern.ch/jira/browse/ROOT-6924
cd ${pkgname}-${pkgver}
patch -p1 < ${srcdir}/python3.diff
- #patch -p1 < ${srcdir}/param.diff
2to3 -w etc/dictpch/makepch.py 2>&1 > /dev/null
- #msg 'python2 switch'
- #find . -type f -exec sed -e 's_#!/usr/bin/env python_&2_' \
- # -e 's/python -O/python2 -O/g' \
- # -e 's/python -c/python2 -c/g' -i {} \;
+ ## https://sft.its.cern.ch/jira/browse/ROOT-7640
+ patch -p1 < ${srcdir}/call_PyErr_Clear_if_no_such_attribute.patch
}
build() {
diff --git a/call_PyErr_Clear_if_no_such_attribute.patch b/call_PyErr_Clear_if_no_such_attribute.patch
new file mode 100644
index 000000000000..c1c401562a01
--- /dev/null
+++ b/call_PyErr_Clear_if_no_such_attribute.patch
@@ -0,0 +1,16 @@
+diff --git a/bindings/pyroot/src/Utility.cxx b/bindings/pyroot/src/Utility.cxx
+index ffeae8e..d3ba063 100644
+--- a/bindings/pyroot/src/Utility.cxx
++++ b/bindings/pyroot/src/Utility.cxx
+@@ -219,8 +219,10 @@ Bool_t PyROOT::Utility::AddToClass(
+ Bool_t PyROOT::Utility::AddToClass( PyObject* pyclass, const char* label, const char* func )
+ {
+ PyObject* pyfunc = PyObject_GetAttrString( pyclass, const_cast< char* >( func ) );
+- if ( ! pyfunc )
++ if ( ! pyfunc ) {
++ PyErr_Clear();
+ return kFALSE;
++ }
+
+ Bool_t isOk = PyObject_SetAttrString( pyclass, const_cast< char* >( label ), pyfunc ) == 0;
+