summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO64
-rw-r--r--PKGBUILD68
-rw-r--r--root-extra.install10
-rw-r--r--settings.cmake65
4 files changed, 155 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7fd9b95a7ae8..fde45e5daa27 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,63 +1,91 @@
pkgbase = root-extra
pkgdesc = C++ data analysis framework and interpreter from CERN with extra features enabled.
- pkgver = 6.14.04
- pkgrel = 2
+ pkgver = 6.14.08
+ pkgrel = 1
url = http://root.cern.ch
- install = root-extra.install
arch = i686
arch = x86_64
license = LGPL2.1
+ makedepends = avahi
+ makedepends = ccache
+ makedepends = cern-vdt
+ makedepends = cfitsio
makedepends = cmake
- makedepends = llvm50>=5.0.2-5
+ makedepends = fcgi
+ makedepends = fftw
+ makedepends = ftgl
+ makedepends = blas
+ makedepends = gcc-fortran
+ makedepends = gl2ps
+ makedepends = glew
+ makedepends = go-pie
+ makedepends = graphviz
+ makedepends = gsl
+ makedepends = hicolor-icon-theme
+ makedepends = intel-tbb
+ makedepends = libafterimage
+ makedepends = libmariadbclient
+ makedepends = ocaml
+ makedepends = ocaml-ctypes
+ makedepends = openssl
+ makedepends = postgresql-libs
+ makedepends = pythia>=8.2.23-3
+ makedepends = python
+ makedepends = python-numpy
+ makedepends = qt4
+ makedepends = sqlite
+ makedepends = tex-gyre-fonts
+ makedepends = unixodbc
+ makedepends = unuran
+ makedepends = vc
+ makedepends = xmlrpc-c
+ makedepends = xrootd>=4.6.0-2
+ makedepends = xxhash>=0.6.5-1
+ makedepends = z3
depends = cfitsio
depends = cern-vdt
+ depends = blas
depends = fcgi
depends = fftw
depends = ftgl
depends = gl2ps
depends = glew
depends = graphviz
- depends = gsl
depends = hicolor-icon-theme
depends = intel-tbb
depends = libafterimage
- depends = libiodbc
depends = libmariadbclient
depends = postgresql-libs
depends = pythia>=8.2.23-3
- depends = python
- depends = sqlite
+ depends = python-numpy
+ depends = qt4
depends = tex-gyre-fonts
depends = unixodbc
depends = unuran
depends = xmlrpc-c
depends = xrootd>=4.6.0-2
depends = xxhash>=0.6.5-1
- optdepends = blas: Optional extensions to TMVA
- optdepends = go: Go language support
optdepends = gcc-fortran: Enable the Fortran components of ROOT
- optdepends = ocaml: OCAML support
- optdepends = python-numpy: numpy bindings for PyMVA
optdepends = tcsh: Legacy CSH support
- optdepends = z3: Z3 Theorem prover support
+ optdepends = unuran: Support non-uniform random numbers
+ optdepends = vc: Add types for portable and intuitive SIMD programming
+ optdepends = xrootd: Support remote file server and client
provides = root
provides = root-extra
conflicts = root
options = !emptydirs
- source = https://root.cern.ch/download/root_v6.14.04.source.tar.gz
- source = root-extra.install
+ source = https://root.cern.ch/download/root_v6.14.08.source.tar.gz
source = root.sh
source = root.xml
source = rootd
source = settings.cmake
source = exclude_clang_from_install_directive.patch
source = fix_tmva_numpy_dependency.patch
- sha256sums = 463ec20692332a422cfb5f38c78bedab1c40ab4d81be18e99b50cf9f53f596cf
- sha256sums = f1796729b0403026382bca43329692f5356c8ec46fc2c09f799a8b3d12d49a6f
+ sha256sums = 1b63b51cfb4dc20f1f5749faac6bbd1098eccab777f8b49911257d77186c73c4
sha256sums = 9d1f8e7ad923cb5450386edbbce085d258653c0160419cdd6ff154542cc32bd7
sha256sums = 50c08191a5b281a39aa05ace4feb8d5405707b4c54a5dcba061f954649c38cb0
sha256sums = 3c45b03761d5254142710b7004af0077f18efece7c95511910140d0542c8de8a
- sha256sums = 05c584402583ec85f813af83683b85bea33b58e103f25294c0c826de76a4baa2
+ sha256sums = e73ea28766add34072506c4e50968cdfd744eef44b836ef4f58426916978409b
sha256sums = f2d07ccfa65dc0db8b41e36b67cc4cf471a0dec318f0f9f883711c5d2c0e296b
sha256sums = bc0a31992c0da5004d6d9be8f0236e77185245f218ec49a6d86d9279c7bbb868
diff --git a/PKGBUILD b/PKGBUILD
index 3fdace453b6a..99165617a039 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,63 +6,91 @@
pkgname=root-extra
_pkgname=root
-pkgver=6.14.04
-pkgrel=2
+pkgver=6.14.08
+pkgrel=1
provides=('root' 'root-extra')
conflicts=('root')
pkgdesc='C++ data analysis framework and interpreter from CERN with extra features enabled.'
arch=('i686' 'x86_64')
url='http://root.cern.ch'
license=('LGPL2.1')
-makedepends=('cmake'
- 'llvm50>=5.0.2-5')
+makedepends=('avahi'
+ 'ccache'
+ 'cern-vdt'
+ 'cfitsio'
+ 'cmake'
+ 'fcgi'
+ 'fftw'
+ 'ftgl'
+ 'blas'
+ 'gcc-fortran'
+ 'gl2ps'
+ 'glew'
+ 'go-pie'
+ 'graphviz'
+ 'gsl'
+ 'hicolor-icon-theme'
+ 'intel-tbb'
+ 'libafterimage'
+ 'libmariadbclient'
+ 'ocaml'
+ 'ocaml-ctypes'
+ 'openssl'
+ 'postgresql-libs'
+ 'pythia>=8.2.23-3'
+ 'python'
+ 'python-numpy'
+ 'qt4'
+ 'sqlite'
+ 'tex-gyre-fonts' # solve the pixelized font problem as per Arch Wiki
+ 'unixodbc'
+ 'unuran'
+ 'vc'
+ 'xmlrpc-c'
+ 'xrootd>=4.6.0-2'
+ 'xxhash>=0.6.5-1'
+ 'z3')
depends=('cfitsio'
'cern-vdt'
+ 'blas'
'fcgi'
'fftw'
'ftgl'
'gl2ps'
'glew'
'graphviz'
- 'gsl'
'hicolor-icon-theme'
'intel-tbb'
'libafterimage'
- 'libiodbc'
'libmariadbclient'
'postgresql-libs'
'pythia>=8.2.23-3'
- 'python'
- 'sqlite'
+ 'python-numpy'
+ 'qt4'
'tex-gyre-fonts' # solve the pixelized font problem as per Arch Wiki
'unixodbc'
'unuran'
'xmlrpc-c'
'xrootd>=4.6.0-2'
'xxhash>=0.6.5-1')
-optdepends=('blas: Optional extensions to TMVA'
- 'go: Go language support'
- 'gcc-fortran: Enable the Fortran components of ROOT'
- 'ocaml: OCAML support'
- 'python-numpy: numpy bindings for PyMVA'
+optdepends=('gcc-fortran: Enable the Fortran components of ROOT'
'tcsh: Legacy CSH support'
- 'z3: Z3 Theorem prover support')
+ 'unuran: Support non-uniform random numbers'
+ 'vc: Add types for portable and intuitive SIMD programming'
+ 'xrootd: Support remote file server and client')
options=('!emptydirs')
-install=root-extra.install
source=("https://root.cern.ch/download/root_v${pkgver}.source.tar.gz"
- 'root-extra.install'
'root.sh'
'root.xml'
'rootd'
'settings.cmake'
'exclude_clang_from_install_directive.patch'
'fix_tmva_numpy_dependency.patch')
-sha256sums=('463ec20692332a422cfb5f38c78bedab1c40ab4d81be18e99b50cf9f53f596cf'
- 'f1796729b0403026382bca43329692f5356c8ec46fc2c09f799a8b3d12d49a6f'
+sha256sums=('1b63b51cfb4dc20f1f5749faac6bbd1098eccab777f8b49911257d77186c73c4'
'9d1f8e7ad923cb5450386edbbce085d258653c0160419cdd6ff154542cc32bd7'
'50c08191a5b281a39aa05ace4feb8d5405707b4c54a5dcba061f954649c38cb0'
'3c45b03761d5254142710b7004af0077f18efece7c95511910140d0542c8de8a'
- '05c584402583ec85f813af83683b85bea33b58e103f25294c0c826de76a4baa2'
+ 'e73ea28766add34072506c4e50968cdfd744eef44b836ef4f58426916978409b'
'f2d07ccfa65dc0db8b41e36b67cc4cf471a0dec318f0f9f883711c5d2c0e296b'
'bc0a31992c0da5004d6d9be8f0236e77185245f218ec49a6d86d9279c7bbb868')
prepare() {
@@ -85,7 +113,7 @@ prepare() {
build() {
cd "${srcdir}/build"
- make ${MAKEFLAGS}
+ make
}
package() {
diff --git a/root-extra.install b/root-extra.install
deleted file mode 100644
index 4724af5cf1c4..000000000000
--- a/root-extra.install
+++ /dev/null
@@ -1,10 +0,0 @@
-post_install () {
- echo "Optional packages/features will only be activated"
- echo "if the optional dependencies are installed before"
- echo "the package compilation has started. Please reco-"
- echo "mpile as needed."
-}
-
-post_upgrade () {
- post_install
-}
diff --git a/settings.cmake b/settings.cmake
index 18301c5a61b1..04df7ee3fc82 100644
--- a/settings.cmake
+++ b/settings.cmake
@@ -3,56 +3,113 @@ set (BUILD_SHARED_LIBS OFF CACHE BOOL "" FORCE) # this option is currently inco
set (CMAKE_INSTALL_PREFIX /usr CACHE PATH "" FORCE)
set (CMAKE_INSTALL_SYSCONFDIR /etc/root CACHE PATH "" FORCE)
set (CMAKE_INSTALL_DATAROOTDIR /usr/share CACHE PATH "" FORCE)
+set (afdsmgrd OFF CACHE BOOL "" FORCE) # broken, bug in string_view include
+set (afs OFF CACHE BOOL "" FORCE)
+set (alien OFF CACHE BOOL "" FORCE)
+set (all OFF CACHE BOOL "" FORCE)
set (asimage ON CACHE BOOL "" FORCE)
+set (astiff ON CACHE BOOL "" FORCE)
+set (bonjour ON CACHE BOOL "" FORCE)
set (builtin_afterimage OFF CACHE BOOL "" FORCE)
set (builtin_clang ON CACHE BOOL "" FORCE)
+set (CLANG_ENABLE_STATIC_ANALYZER ON CACHE BOOL "" FORCE)
+set (CLANG_ANALYZER_BUILD_Z3 ON CACHE BOOL "" FORCE)
+set (builtin_cfitsio OFF CACHE BOOL "" FORCE)
+set (builtin_davix OFF CACHE BOOL "" FORCE)
+set (builtin_fftw3 OFF CACHE BOOL "" FORCE)
set (builtin_ftgl OFF CACHE BOOL "" FORCE)
set (builtin_freetype OFF CACHE BOOL "" FORCE)
set (builtin_gl2ps OFF CACHE BOOL "" FORCE)
set (builtin_glew OFF CACHE BOOL "" FORCE)
+set (builtin_gsl OFF CACHE BOOL "" FORCE)
set (builtin_lzma OFF CACHE BOOL "" FORCE)
-set (builtin_llvm OFF CACHE BOOL "" FORCE)
+set (builtin_llvm ON CACHE BOOL "" FORCE)
+set (builtin_openssl OFF CACHE BOOL "" FORCE)
set (builtin_pcre OFF CACHE BOOL "" FORCE)
set (builtin_tbb OFF CACHE BOOL "" FORCE)
set (builtin_unuran OFF CACHE BOOL "" FORCE)
set (builtin_xxhash OFF CACHE BOOL "" FORCE)
+set (builtin_xrootd OFF CACHE BOOL "" FORCE)
set (builtin_zlib OFF CACHE BOOL "" FORCE)
set (castor OFF CACHE BOOL "" FORCE)
+set (ccache ON CACHE BOOL "" FORCE)
set (chirp OFF CACHE BOOL "" FORCE)
set (cling ON CACHE BOOL "" FORCE)
+set (cocoa OFF CACHE BOOL "" FORCE) # MacOS only
+set (cxx11 OFF CACHE BOOL "" FORCE)
+set (cxx14 OFF CACHE BOOL "" FORCE)
set (cxx17 ON CACHE BOOL "" FORCE)
set (davix OFF CACHE BOOL "" FORCE)
set (dcache OFF CACHE BOOL "" FORCE)
+set (exceptions ON CACHE BOOL "" FORCE)
+set (explicitlink ON CACHE BOOL "" FORCE)
set (fail-on-missing ON CACHE BOOL "" FORCE)
+set (fftw3 ON CACHE BOOL "" FORCE)
set (fitsio ON CACHE BOOL "" FORCE)
set (fortran ON CACHE BOOL "" FORCE)
+set (gdml ON CACHE BOOL "" FORCE)
+set (geocad OFF CACHE BOOL "" FORCE)
+set (genvector ON CACHE BOOL "" FORCE)
set (gfal OFF CACHE BOOL "" FORCE)
set (gl2ps ON CACHE BOOL "" FORCE)
set (glite OFF CACHE BOOL "" FORCE)
+set (globus OFF CACHE BOOL "" FORCE)
+set (gminimal OFF CACHE BOOL "" FORCE)
set (gnuinstall ON CACHE BOOL "" FORCE)
set (gsl_shared ON CACHE BOOL "" FORCE)
+set (gviz ON CACHE BOOL "" FORCE)
set (hdfs OFF CACHE BOOL "" FORCE)
set (http ON CACHE BOOL "" FORCE)
+set (imt ON CACHE BOOL "" FORCE)
+set (jemalloc OFF CACHE BOOL "" FORCE)
+set (krb5 ON CACHE BOOL "" FORCE)
+set (ldap ON CACHE BOOL "" FORCE)
set (mathmore ON CACHE BOOL "" FORCE)
+set (memstat OFF CACHE BOOL "" FORCE)
+set (minimal OFF CACHE BOOL "" FORCE)
set (minuit2 ON CACHE BOOL "" FORCE)
set (monalisa OFF CACHE BOOL "" FORCE)
set (mt ON CACHE BOOL "" FORCE)
+set (mysql ON CACHE BOOL "" FORCE)
+set (odbc ON CACHE BOOL "" FORCE)
set (opengl ON CACHE BOOL "" FORCE)
+set (OpenGL_GL_PREFERENCE GLVND CACHE STRING "" FORCE) # use new policy since 3.11
set (oracle OFF CACHE BOOL "" FORCE)
-set (python3 ON CACHE BOOL "" FORCE)
+set (pch ON CACHE BOOL "" FORCE)
+set (pgsql ON CACHE BOOL "" FORCE)
set (pythia6 OFF CACHE BOOL "" FORCE)
set (pythia6_nolink OFF CACHE BOOL "" FORCE)
set (pythia8 ON CACHE BOOL "" FORCE)
-set (qt OFF CACHE BOOL "" FORCE)
-set (qtgsi OFF CACHE BOOL "" FORCE)
+set (python3 ON CACHE BOOL "" FORCE)
+set (qt ON CACHE BOOL "" FORCE)
+set (qtgsi ON CACHE BOOL "" FORCE)
set (rfio OFF CACHE BOOL "" FORCE)
set (roofit ON CACHE BOOL "" FORCE)
+set (root7 ON CACHE BOOL "" FORCE)
+set (roottest OFF CACHE BOOL "" FORCE)
+set (rpath OFF CACHE BOOL "" FORCE)
+set (ruby OFF CACHE BOOL "" FORCE) # not supported
+set (runtime_cxxmodules OFF CACHE BOOL "" FORCE) # broken - circular dependency
+set (r OFF CACHE BOOL "" FORCE) # requires r-rcpp
+set (sapdb OFF CACHE BOOL "" FORCE) # not implemented
+set (shadowpw ON CACHE BOOL "" FORCE)
set (shared ON CACHE BOOL "" FORCE)
+set (soversion OFF CACHE BOOL "" FORCE)
+set (sqlite ON CACHE BOOL "" FORCE)
+set (srp OFF CACHE BOOL "" FORCE) # not implemented
+set (ssl ON CACHE BOOL "" FORCE)
set (table ON CACHE BOOL "" FORCE)
set (tbb ON CACHE BOOL "" FORCE)
+set (tcmalloc OFF CACHE BOOL "" FORCE)
set (testing OFF CACHE BOOL "" FORCE)
+set (thread ON CACHE BOOL "" FORCE) # cannot be disabled
set (tmva ON CACHE BOOL "" FORCE)
+set (tmva-cpu ON CACHE BOOL "" FORCE)
set (unuran ON CACHE BOOL "" FORCE)
+set (vc ON CACHE BOOL "" FORCE)
+set (vdt ON CACHE BOOL "" FORCE)
+set (winrtdebug OFF CACHE BOOL "" FORCE) # windows only
set (x11 ON CACHE BOOL "" FORCE)
set (xft ON CACHE BOOL "" FORCE)
+set (xml ON CACHE BOOL "" FORCE)
set (xrootd ON CACHE BOOL "" FORCE)