summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
-rw-r--r--rootsh-1.5.3-open-needs-3-args.patch12
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a5a3c1b61af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Oct 8 21:03:21 UTC 2017
+pkgbase = rootsh
+ pkgdesc = wrapper for shells which logs all echoed keystrokes and terminal output to a file and/or to syslog
+ pkgver = 1.5.3
+ pkgrel = 1
+ url = https://sourceforge.net/projects/rootsh/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = armv6h
+ license = GPL2
+ depends = glibc
+ source = https://download.sourceforge.net/rootsh/rootsh-1.5.3.tar.gz
+ source = rootsh-1.5.3-open-needs-3-args.patch
+ sha256sums = 7ad043c8cbb02743b5066822bd2aa1b3313d2675d235edea1db287e7138611ec
+ sha256sums = 03e3675bfa6dbc817d36f6d131131e7cc0195c19f26cf7b528db01e4194f731b
+
+pkgname = rootsh
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..553bac6490ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Swift Geek
+pkgname=rootsh
+pkgver=1.5.3
+pkgrel=1
+pkgdesc="wrapper for shells which logs all echoed keystrokes and terminal output to a file and/or to syslog"
+arch=('i686' 'x86_64' 'armv7h' 'armv6h')
+url="https://sourceforge.net/projects/rootsh/"
+license=('GPL2')
+depends=('glibc')
+source=("https://download.sourceforge.net/rootsh/$pkgname-$pkgver.tar.gz" 'rootsh-1.5.3-open-needs-3-args.patch')
+sha256sums=('7ad043c8cbb02743b5066822bd2aa1b3313d2675d235edea1db287e7138611ec'
+ '03e3675bfa6dbc817d36f6d131131e7cc0195c19f26cf7b528db01e4194f731b')
+
+prepare() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/rootsh-1.5.3-open-needs-3-args.patch"
+}
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/rootsh-1.5.3-open-needs-3-args.patch b/rootsh-1.5.3-open-needs-3-args.patch
new file mode 100644
index 000000000000..63bf25636ffc
--- /dev/null
+++ b/rootsh-1.5.3-open-needs-3-args.patch
@@ -0,0 +1,12 @@
+diff -up rootsh-1.5.3/src/rootsh.c.BAD rootsh-1.5.3/src/rootsh.c
+--- rootsh-1.5.3/src/rootsh.c.BAD 2008-05-14 16:38:30.000000000 -0400
++++ rootsh-1.5.3/src/rootsh.c 2008-05-14 16:38:37.000000000 -0400
+@@ -680,7 +680,7 @@ int beginlogging(void) {
+ // Open the logfile
+ */
+ if ((logFile = open(logFileName, O_RDWR|O_CREAT|O_SYNC|O_CREAT|O_APPEND|
+- S_IRUSR|S_IWUSR)) == -1) {
++ S_IRUSR|S_IWUSR, 0777)) == -1) {
+ perror(logFileName);
+ return(0);
+ }