summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD34
2 files changed, 7 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be2c32dff302..1a057e94e429 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Dec 19 18:39:04 UTC 2017
+# Thu Dec 21 22:29:48 UTC 2017
pkgbase = ros-ardent-ament-package
pkgdesc = ROS - The parser for the manifest files in the ament buildsystem.
pkgver = 0.4.0
@@ -9,8 +9,8 @@ pkgbase = ros-ardent-ament-package
license = Apache License 2.0
makedepends = cmake
makedepends = ros-build-tools
- depends = python3-setuptools
- depends = python3-pyparsing
+ depends = python-pyparsing
+ depends = python-setuptools
source = ros-ardent-ament-package-0.4.0-0.tar.gz::https://github.com/ros2-gbp/ament_package-release/archive/release/ardent/ament_package/0.4.0-0.tar.gz
sha256sums = 2180cff34c1e6f218e90b5e7e137eefc65403469ed4ffe5147e516223480c457
diff --git a/PKGBUILD b/PKGBUILD
index 2588cfefd16e..3e32f255c9c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,8 +16,8 @@ makedepends=('cmake' 'ros-build-tools'
ros_depends=()
depends=(${ros_depends[@]}
- python3-setuptools
- python3-pyparsing)
+ python-pyparsing
+ python-setuptools)
# Git version (e.g. for debugging)
# _tag=release/ardent/ament_package/${pkgver}-${_pkgver_patch}
@@ -30,33 +30,7 @@ _dir="ament_package-release-release-ardent-ament_package-${pkgver}-${_pkgver_pat
source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros2-gbp/ament_package-release/archive/release/ardent/ament_package/${pkgver}-${_pkgver_patch}.tar.gz")
sha256sums=('2180cff34c1e6f218e90b5e7e137eefc65403469ed4ffe5147e516223480c457')
-build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/ardent/setup.bash ] && source /opt/ros/ardent/setup.bash
-
- # Create build directory
- [ -d "${srcdir}/build" ] || mkdir "${srcdir}/build"
- cd "${srcdir}/build"
-
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 "${srcdir}/${_dir}"
-
- # Build project
- cmake "${srcdir}/${_dir}" \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/ardent \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.5m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.5m.so \
- -DPYTHON_BASENAME=.cpython-35m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF \
- -DCATKIN_ENABLE_TESTING=OFF
- make
-}
-
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/${_dir}"
+ python setup.py install --root="$pkgdir" --prefix="/opt/ros/ardent" --optimize=1
}