summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD61
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..216f7f4058ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Dec 19 18:39:07 UTC 2017
+pkgbase = ros-ardent-ament-tools
+ pkgdesc = ROS - The command line tools for the ament buildsystem.
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = http://www.ros.org/
+ arch = any
+ license = Apache License 2.0
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-ardent-ament-package
+ makedepends = ros-ardent-osrf-pycommon
+ source = ros-ardent-ament-tools-0.4.0-0.tar.gz::https://github.com/ros2-gbp/ament_tools-release/archive/release/ardent/ament_tools/0.4.0-0.tar.gz
+ sha256sums = 99292e3bd164d05a29a9b0b21091e5806b7fe4b85b43856991d0b7e8b3caf4a8
+
+pkgname = ros-ardent-ament-tools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e067db14438
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - The command line tools for the ament buildsystem."
+url='http://www.ros.org/'
+
+pkgname='ros-ardent-ament-tools'
+pkgver='0.4.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('Apache License 2.0')
+
+ros_makedepends=(ros-ardent-ament-package
+ ros-ardent-osrf-pycommon)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=()
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/ardent/ament_tools/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros2-gbp/ament_tools-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ament_tools-release-release-ardent-ament_tools-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros2-gbp/ament_tools-release/archive/release/ardent/ament_tools/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('99292e3bd164d05a29a9b0b21091e5806b7fe4b85b43856991d0b7e8b3caf4a8')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/ardent/setup.bash ] && source /opt/ros/ardent/setup.bash
+
+ # Create build directory
+ [ -d "${srcdir}/build" ] || mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 "${srcdir}/${_dir}"
+
+ # Build project
+ cmake "${srcdir}/${_dir}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/ardent \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.5m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.5m.so \
+ -DPYTHON_BASENAME=.cpython-35m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DCATKIN_ENABLE_TESTING=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}