summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--fix-urdf-lib-compat.patch61
3 files changed, 78 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e009aced247..6ab97a278aab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ros-indigo-gripper-action-controller
pkgdesc = ROS - The gripper_action_controller package.
- pkgver = 0.9.2
+ pkgver = 0.9.4
pkgrel = 1
url = http://www.ros.org/
arch = any
@@ -35,8 +35,10 @@ pkgbase = ros-indigo-gripper-action-controller
depends = ros-indigo-actionlib
depends = ros-indigo-cmake-modules
depends = ros-indigo-urdf
- source = gripper_action_controller::git+https://github.com/ros-gbp/ros_controllers-release.git#tag=release/indigo/gripper_action_controller/0.9.2-0
- md5sums = SKIP
+ source = gripper_action_controller::git+https://github.com/ros-gbp/ros_controllers-release.git#tag=release/indigo/gripper_action_controller/0.9.4-0
+ source = fix-urdf-lib-compat.patch
+ sha256sums = SKIP
+ sha256sums = e17c3af98a56d448e8077e796734f380ec560575b895b23f78c1944cd69f4cd8
pkgname = ros-indigo-gripper-action-controller
diff --git a/PKGBUILD b/PKGBUILD
index 00564e1f9193..794b82e596de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgdesc="ROS - The gripper_action_controller package."
url='http://www.ros.org/'
pkgname='ros-indigo-gripper-action-controller'
-pkgver='0.9.2'
+pkgver='0.9.4'
_pkgver_patch=0
arch=('any')
pkgrel=1
@@ -44,8 +44,17 @@ depends=(${ros_depends[@]})
_tag=release/indigo/gripper_action_controller/${pkgver}-${_pkgver_patch}
_dir=gripper_action_controller
-source=("${_dir}"::"git+https://github.com/ros-gbp/ros_controllers-release.git"#tag=${_tag})
-md5sums=('SKIP')
+source=(
+ "${_dir}"::"git+https://github.com/ros-gbp/ros_controllers-release.git"#tag=${_tag}
+ 'fix-urdf-lib-compat.patch'
+)
+sha256sums=('SKIP'
+ 'e17c3af98a56d448e8077e796734f380ec560575b895b23f78c1944cd69f4cd8')
+
+prepare() {
+ cd ${srcdir}/${_dir}
+ patch -Np1 -i ${srcdir}/fix-urdf-lib-compat.patch
+}
build() {
# Use ROS environment variables
diff --git a/fix-urdf-lib-compat.patch b/fix-urdf-lib-compat.patch
new file mode 100644
index 000000000000..776b567ccaa2
--- /dev/null
+++ b/fix-urdf-lib-compat.patch
@@ -0,0 +1,61 @@
+diff --git a/include/gripper_action_controller/gripper_action_controller_impl.h b/include/gripper_action_controller/gripper_action_controller_impl.h
+index 29007412..0874819d 100644
+--- a/include/gripper_action_controller/gripper_action_controller_impl.h
++++ b/include/gripper_action_controller/gripper_action_controller_impl.h
+@@ -41,9 +41,9 @@ std::string getLeafNamespace(const ros::NodeHandle& nh)
+ return complete_ns.substr(id + 1);
+ }
+
+-boost::shared_ptr<urdf::Model> getUrdf(const ros::NodeHandle& nh, const std::string& param_name)
++std::shared_ptr<urdf::Model> getUrdf(const ros::NodeHandle& nh, const std::string& param_name)
+ {
+- boost::shared_ptr<urdf::Model> urdf(new urdf::Model);
++ std::shared_ptr<urdf::Model> urdf(new urdf::Model);
+
+ std::string urdf_str;
+ // Check for robot_description in proper namespace
+@@ -53,19 +53,19 @@ boost::shared_ptr<urdf::Model> getUrdf(const ros::NodeHandle& nh, const std::str
+ {
+ ROS_ERROR_STREAM("Failed to parse URDF contained in '" << param_name << "' parameter (namespace: " <<
+ nh.getNamespace() << ").");
+- return boost::shared_ptr<urdf::Model>();
++ return std::shared_ptr<urdf::Model>();
+ }
+ }
+ // Check for robot_description in root
+ else if (!urdf->initParam("robot_description"))
+ {
+ ROS_ERROR_STREAM("Failed to parse URDF contained in '" << param_name << "' parameter");
+- return boost::shared_ptr<urdf::Model>();
++ return std::shared_ptr<urdf::Model>();
+ }
+ return urdf;
+ }
+
+-typedef boost::shared_ptr<const urdf::Joint> UrdfJointConstPtr;
++typedef std::shared_ptr<const urdf::Joint> UrdfJointConstPtr;
+ std::vector<UrdfJointConstPtr> getUrdfJoints(const urdf::Model& urdf, const std::vector<std::string>& joint_names)
+ {
+ std::vector<UrdfJointConstPtr> out;
+@@ -157,7 +157,7 @@ bool GripperActionController<HardwareInterface>::init(HardwareInterface* hw,
+ }
+
+ // URDF joints
+- boost::shared_ptr<urdf::Model> urdf = getUrdf(root_nh, "robot_description");
++ std::shared_ptr<urdf::Model> urdf = getUrdf(root_nh, "robot_description");
+ if (!urdf)
+ {
+ return false;
+diff --git a/include/gripper_action_controller/hardware_interface_adapter.h b/include/gripper_action_controller/hardware_interface_adapter.h
+index cd896e19..22f72084 100644
+--- a/include/gripper_action_controller/hardware_interface_adapter.h
++++ b/include/gripper_action_controller/hardware_interface_adapter.h
+@@ -182,7 +182,7 @@ public:
+ }
+
+ private:
+- typedef boost::shared_ptr<control_toolbox::Pid> PidPtr;
++ typedef std::shared_ptr<control_toolbox::Pid> PidPtr;
+ PidPtr pid_;
+ hardware_interface::JointHandle* joint_handle_ptr_;
+ };