summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
2 files changed, 18 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fda4338e4941..96339f4644ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Nov 24 08:52:37 UTC 2016
pkgbase = ros-indigo-rocon-ebnf
pkgdesc = ROS - Internal packaging of the 0.91 version of the simple python EBNF parser written by LParis.
pkgver = 0.1.23
- pkgrel = 1
+ pkgrel = 2
url = http://lparis45.free.fr/rp.html
arch = any
license = GPL
makedepends = cmake
- makedepends = git
makedepends = ros-build-tools
makedepends = ros-indigo-catkin
makedepends = python2-catkin-pkg
- source = rocon_ebnf::git+https://github.com/yujinrobot-release/rocon_tools-release.git#tag=release/indigo/rocon_ebnf/0.1.23-0
- md5sums = SKIP
+ source = ros-indigo-rocon-ebnf-0.1.23-1.tar.gz::https://github.com/yujinrobot-release/rocon_tools-release/archive/release/indigo/rocon_ebnf/0.1.23-1.tar.gz
+ sha256sums = fe6ff8b90114fc61e939c833bb03c38d211d8542928e6a2737595706015b9ec5
pkgname = ros-indigo-rocon-ebnf
diff --git a/PKGBUILD b/PKGBUILD
index 2c39766a5ad7..1ab5fb4f5229 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,23 +5,29 @@ url='http://lparis45.free.fr/rp.html'
pkgname='ros-indigo-rocon-ebnf'
pkgver='0.1.23'
-_pkgver_patch=0
+_pkgver_patch=1
arch=('any')
-pkgrel=1
+pkgrel=2
license=('GPL')
ros_makedepends=(ros-indigo-catkin)
-makedepends=('cmake' 'git' 'ros-build-tools'
+makedepends=('cmake' 'ros-build-tools'
${ros_makedepends[@]}
python2-catkin-pkg)
ros_depends=()
depends=(${ros_depends[@]})
-_tag=release/indigo/rocon_ebnf/${pkgver}-${_pkgver_patch}
-_dir=rocon_ebnf
-source=("${_dir}"::"git+https://github.com/yujinrobot-release/rocon_tools-release.git"#tag=${_tag})
-md5sums=('SKIP')
+# Git version (e.g. for debugging)
+# _tag=release/indigo/rocon_ebnf/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/yujinrobot-release/rocon_tools-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="rocon_tools-release-release-indigo-rocon_ebnf-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/yujinrobot-release/rocon_tools-release/archive/release/indigo/rocon_ebnf/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('fe6ff8b90114fc61e939c833bb03c38d211d8542928e6a2737595706015b9ec5')
build() {
# Use ROS environment variables